Cannot find pi after updating

What is the problem?

I updated my pi to the latest version today after not using it for a while, during the update it lost connection and now im receving an error saying the server is not running and a tmc connection error on my printer. Im not able to access the UI

What did you already try to solve it?

I am not too familiar with the software and terms people are using on here, for instance how to access safe mode ect.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

The OctoPrint server is currently not running

If you just started up your Raspberry Pi, please wait a couple of seconds, then try to refresh this page.

If the issue persists, please log into your Raspberry Pi via SSH and check the following:

  • Verify that the process is running: ps -ef | grep -i octoprint | grep -i python should show a python process:

pi@octopi:~ $ ps -ef | grep -i octoprint | grep -i python
pi 1441 1 6 11:12 ? 00:00:15 /home/pi/oprint/bin/python
/home/pi/oprint/bin/octoprint --host= --port=5000

  • If it isn't, the question is why. Take a look into ~/.octoprint/logs/octoprint.log , there might be an error logged in there that helps to determine what's wrong.
  • You might also want to try if you can restart the server (if no obvious error is visible): sudo service octoprint restart .

If all that doesn't help to trouble shoot the issue, you can seek support on the OctoPrint Community Forum. Please provide your OctoPi and OctoPrint versions as well as your octoprint.log and explain what you already tried and observed as detailed as possible.

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


Try if you can access the recovery page under http://octopi.local/recovery / http://octopi/recovery / http://your-ip/recovery and click on Restart Octoprint in safe mode

Try logging in to the Pi over SSH, if you can do that you can run the troubleshooting commands and find the octoprint.log.