Cannot get fresh install to work on DietPi

What is the problem?

Doing a clean install of DietPi and Octoprint and getting lots of issues

What did you already try to solve it?

Did a fresh flash, tried uninstalling and reinstalling python3.
When I remove and re-add Octoprint - I get a bunch of distutil errors.
When I type "octoprint serve" - I get address already in use
I can see "octoprint" when I type "top"
There is no .octoprint folder in the root or dietpi user directories

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

Cannot access webui so how am I supposed to get this? Can't find logs either.

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Fresh Dietpi install ARM v8 64 bit on Raspberry Pi 4b 4GB
Octoprint installed through "dietpi-software"

I suspect that you'll need to look for assistance in the dietpi community, because that install is not an official distribution. If you could share the actual errors it might help in finding a solution.

OK - I will just switch the Octopi image - now just to figure out why that doesn't want to connect to wifi.

As @jneilliii said: OctoPi is made for the Raspberry Pi.
Some things may work on a DietPi, others not.
It starts with a different wifi chip on a different address.

dietpi is it's own image similar to octopi that runs on a couple of different platforms. I actually have a VMWare image of it running for testing purposes previously. It makes it easy for installing different applications/services on a single device, ie running octoprint, pihole, MQTT server, etc.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.