Cannot get print to center

What is the problem?

I have a Tevo Tarantula Printer(completely rebuilt) and no matter what I configure I cannot get the print to center in the middle of bed from Octopi. The Y center is good but the X is 20 mm to the right. If I print from Repetier Host it is centered no issues. Also the GCODE Viewer is displaying the print at the top right off the grid.

My print dimension are X 220 Y 280 Z 280. I set this in the printer profile. I created a new profile and same results. I use Slic3r to slice to gcode.

If do an auto home G28 the print head goes to the center of the bed. When the print starts it start 20mm to the right from the center on the X axis.

I had a previous Octopi don't recall the version, but did not have this issue, I had to reload the RPi with a new Octopi image and set it back up, I did not save the original parameters.

What did you already try to solve it?


Have you tried running in safe mode and if so did it solve the issue?


Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)


I tried to recenter the bed and reverify the parameters in Marlin config.h, I deleted the profiles or created new profiles and checked the bed dimension were correct.

I searched for Octoprint not printing centered.

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


Version 0.17.0, running on Raspberry Pi 3 Model B Rev 1.2

Hello @ajn1963!

Could you please share some logs (<- this is a link) as asked for.
Also the firmware version is quite interesting.

How do you attempt to get to the center from OctoPrint?


Make sure that the origin is set at the center in both OctoPrint and your slicer.

Seems both mine and @Ewald_Ikemann's crystal balls broke today, so a serial.log would be great.


Sorry, in haste I forgot the upload the logs, it was almost 1am and I been tearing through search engines, youtube, and playing with parameters prior to. I apologize for offending everyone by not doing that.

So I tried to tweak the bed setting, I remeasured my bed and made a few small corrections to the bed dimensions in Marlin and the offsets for my probe for a more truer center. I check all the settings in Slic3r, Repetier and Octoprint. When the print starts, if seem as though it starts the print 20mm to the right or smaller prints seem to print at 0,0 on bed center. If I print from Repetier which I want to replace with Octoprint it prints center. The gcode viewer is showing the print at 220,280. (817.0 KB)

The Octoprint Version is 1.4.2 it is constantly reloading and updating. I grabbed the latest to burn at the time when I burned my sd for the RPi a few weeks ago.

Here is the gcode from the last print that should match the serial log.
The last version of Octopi I ran was back in 2018 on an RPi 1 and it worked perfectly and I recall I did little config or setup, I don't recall the version and don't have the sd I flashed for it. Since I got the RPi 3 and flash the latest I had this problem. I created new printer profiles no luck.

20140205_Marvin_KeyChain.gcode (1.0 MB)

No, it is not. You need to head to the printer profile settings and select origin to be in the lower left.
The gcode file is being printed exactly as it is read, which is dead center in the bed. In this case, it is not an OctoPrint issue, and instead firmware configuration.

How large is your bed? Centre according to the gcode file is 100, 100 = bed size of 200mm x 200mm. If this is not correct, then update it in your slicer to the correct size.


My bed is 220 X and 280 Y. Which is what I have set in Slic3r and Repetier where I slice. In Octoprint I have the same parameters of 220 and 280 but have the origin as center and have toggled it to lower left and it still prints right of center for both settings. As I stated before I have combed through Repetier and Slic3r and checked the bed settings and everywhere I can find it is set for 220 280 280 xyz and my prints are centered correctly if I print via Repetier. I am thinking of reburning the Octopi image on the SD and starting over. I don't know what else to check. I looked, seached and check every parameter I could find for my bed dimensions, I remeasured and reflashed recalculated the bed center and offset parameters for Marlin and reflashed my firmware.


This makes more sense, I interpreted the coordinates slightly wrong. Yeah X hovers around ~110, Y ~140 through the print.

Just to confirm: You print the exact same gcode file, uploaded to Repetier and OctoPrint?

Your serial.log confirms that the printer is being told to print at X110, Y140

Try running these commands, and let me know:

  • G90 (absolute positioning)
  • G1 X110 Y140 - is the printer in the centre of the bed?


  • Result from M206

There's not much else, since OctoPrint is telling the printer to go to these coordinates, we can't help it any more thank that.

1 Like

Thank you.

Yes, I set the print, printer, filament parameters in Slic3r, which is integated with Repetier, I slice with Repetier and upload the code to Octoprint or to the SD card in Octoprint to see if it made a difference trying both. It won't center the print.

Again, no issues and perfect print with Repetier oriented perfectly on the center of bed.

I can try running the commands you mentioned. If it don't yield results, I will probably burn down the RPi and reimage Octoprint. It is a new burn so really nothing to save on this image. I did load, uninstall, reload several plugins as most just constantly throw up errors, warning, and decided that if I can't get a simple Octoprint image to work correctly, no sense in trying to make all these plugins and Octolapse work. Might be best just to start with a clean image, and hold off on the plugin hoarding. I am getting alot of errors, warning, notification errors and constantly being prompted to reload with the gist of the message saying something was updated and to reload.

To clarify, for centered prints in the center of the bed, I set my bed dimension 220x280x280 xyz, then select lower left not centered?

I initially selected center, and try switching to lower left and then back and forth a few times, and no luck and the gcode viewer displays the print at 220, 280 and it seems it sets the print 0,0 at the center coordinates if you look at the picture of the Benchy I printed it seems that the print interprets 110,140 as 0,0 for the print and 220,280 for the gcode viewer. I have centered the nozzle and bltouch per:

Then set my Slic3r and Repetier parameters 220,280,280.

Hence, sorry to repeat myself, I am trying to be objective not defensive. I repeated the bed and z probe process several times and reflashed marlin via Arduino IDE with maybe a millimeter or two difference on the z probe but my bed center measurement and calibration come out the same.

Give me a day or two and I will try the recommendations you stated prior, and give an update.

Last time I setup Octoprint it worked with no issue and little, just I tried to boot it one day and Octoprint would not load and could not get it work, and just went back to using Repetier host to print. I finally got the new RPi imaged with Octoprint and trying to use that. I am sick of the USB cable from computer across the floor to my PCB to run prints.

I think you misunderstand how coordinates work with respect to the gcode viewer, and your printer.

The image below is basically like your print bed. 220x280. You notice the origin (0, 0) is in the bottom left hand corner:

This is how your printer's bed is laid out. If you command the printer to move to (0, 0) using G1 X0 Y0 then it will move to where (0, 0) is on this image.

Per your serial.log and uploaded gcode file, the print is being positioned approximately in the middle of the bed, at (110, 140):

When you select 'origin at centre, the gcode viewer interprets the coordinates like this:

And as a result, the print sticks to the top-right, since that is the new position of (110, 140). However this does not make a difference to where the printer prints, so do not worry about changing this. Only difference is to what it renders to you.

Sending the commands from OctoPrint to move to (0, 0) and (110, 140) will help to determine whether this is an OctoPrint, printer or firmware issue - I cannot see how it is changed by OctoPrint, but if you say it is then :man_shrugging: I guess.

Be sure to try safe mode if you think that plugins might be causing an issue - it stops them from interfering.


Thank you again. I got it. G1 X110 Y140 does not go to the center of the bed and matches roughly the start position of where Octoprint starts printing. I think it is probably the Z probe offset is probably incorrect being my new fan mount moved the bltouch from right side to the front of the fan mount. G28 homes the bltouch to bed center(z offset).

However, if I print from Repetier is does print perfectly in the middle of the bed even though a G90 G1 X110 Y140 does not move the nozzled to bed center. The only true correct reference of bed center is from the bltouch probe homes exactly to center. My impression is that Repetier used z offset as relative center where Octoprint uses Nozzle as the relative center?

Hence the bltouch probe does home to bed center(110,240) when issuing a G28, but G1 X110 Y140 does not and is roughly offset 20mm to the right of bed center.

Hence, with that being stated above, Octoprint roughly prints 20mm to the right, but Repetier still prints dead center. This is what throws/threw me off. As well as the rest of us.

Hence when I changed the profile to lower left Gcode display correctly.

Again thank you, I made so many changes, tweaks and searched for solutions to try, I lost the baseline of what I was doing. The second set of eyes always gets to the problem, thank you.

I am going to yet again do a recenter routine of bed re do the z offset per Jim Brown's instructions, and reflash Marlin. And burn a clean image of Octoprint.

Thanks for all the help. I appreciate it.

1 Like