Cannot get the picam to work

Camera model
Raspi Cam (RPI 3 B+)

What is the problem?
I cannot get the camera to work (again). It was working before I reformatted and reinstalled octopi (0.18.0). Now it just does not work on Octopi. Running vcgencmd get_camera shows supported=1 detected=1, libcamera interfaces=0 and even running raspistill saves the camera image. But in octoprint, I don't get any image.

What did you already try to solve it?
I modified /boot/octopi.txt to camera="raspi" to only allow the raspi cam but that didn't work either.

Logs (/var/log/webcamd.log, syslog, dmesg, ... no logs, no support)
/var/log/webcamd.log:

Starting up webcamDaemon...

--- Configuration: ----------------------------
cfg_file:      /boot/octopi.txt
camera:        raspi
usb options:   -r 640x480 -f 10
raspi options: -fps 10
http options:  -w ./www-octopi -n --listen 127.0.0.1

Explicitly USB device:
-----------------------------------------------

Found video devices:
/dev/video0
/dev/video10
/dev/video11
/dev/video12
/dev/video13
/dev/video14
/dev/video15
/dev/video16
/dev/video18
/dev/video20
/dev/video21
/dev/video22
/dev/video23
/dev/video31
Scan again in two minutes

Additional information about your setup (OctoPrint version, OctoPi version, ...)
OctoPrint 1.8.1
OctoPi 0.18.0

Try using camera="usb" in the configuration file, using usb mode instead.

If I remember right, the OctoPi scripts get confused by the recent addition of libcamera interfaces when trying to detect if an RPi camera works. I haven't had a chance to verify and submit a fix, but aware it might be a problem when I saw this. So it never detects that there is a raspberry pi camera connected.

Thanks for the hint. I commented out the line (so it by default tries usb first) and now it works. No idea why it didn't work in the beginning. The only thing I tried after forcing to use the raspi cam was an rpi-update. Maybe that fixed the initial issue.