Cannot login to Octopi via SSH

What is the problem?
I've been trying, and failing, to use Putty to SSH into Octopi. Putty will connect to the Pi, but will not accept any username/password. I cannot login at all.

What did you already try to solve it?
I have tried the default pi/raspberry login combination as well as the ones I assigned with Raspberry Pi Imager and every combination thereof. I also tried the built-in Windows SSH with the same results.

octoprint.log (21.2 KB)

Additional information about your network
The boot disk was created using Raspberry Pi Imager as per Prusa's instructions. My OS is Windows 10. Everything is US standard configuration.


Trying that now.

Created octoprint-password.txt in the main directory using Notepad++ just to be sure. Reinserted the card into the Pi and booted. Still won't accept the password. Just to be clear, I'm a bit of a noob at this.

Notepadd++ might save files as Rich Text Format by default. Verify you are saving the file as text only and try again.

Since when that?
I experienced that NP++ always saves the files in that format I opened them.

Plain text stays plain text if you don't change the file format/extension.

I don't know for certain. That's why I sad "might" :smiley:

1 Like

Just checked. It explicitly says 'Normal Text File (*.txt)'.

This might help:


Check that Edit, EOL Conversion is set to UNIX (LF). It shows in the status bar at the bottom.

Thank you! I will load that as soon as I can.

Still no good. Is there something more reliable than using Raspberry Pi Imager for this?

Raspberry Pi Imager should be the most reliable flashing tool, there are others (Etcher, Win32DiskImager) but none offer a way to configure the WiFi, username and password etc. before flashing.

I assume when you say it doesn't accept your password that you type it and you get 'incorrect password' back? Have to ask because sometimes people are confused by nothing showing up when typing the password.

'Access denied', yes. And I know the password field normally stays blank.

Following this post. I'm have the same problem with access denied.

Just for clarification: You use an English layout keyboard?

Yes. Everything I have is set up for American English.

Could you post a link to those instructions?

Did you change the username and/or password in the pi imager as suggested by the guide?