Cannot restore to new OctoPrint instance on a Pi Zero 2 W

What is the problem?

OctoPrint, on a Pi Zero 2 W, takes hours to restore a backup from a Pi3.

What did you already try to solve it?

Reformatted SD card to try a new image, made another backup, tried a backup from another instance of Octoprint.

Have you tried running in safe mode?

N/A - it's a new install that always goes directly to the install page.

Systeminfo Bundle

This is the bundle from the Pi3. (67.6 KB)

Additional information about your setup

As best I can tell, the Pi Zero 2 W is running Version 1.9.3, but without being able to get past the config screen, I can't be sure.

I had a Pi3 with 2 instances of OctoPrint on it. I kept both up to date. One ran a Prusa printer, one ran an Ender 3 Pro. I made a backup of the Prusa instance and restored it to a Pi Zero 2 W (call it 0P, for Zero Prusa). It was no trouble at all. It did take some time to restore the backup from the Pi3, but at least the status in the window was updating, telling me what was being set up or what plugin was being installed.

After a successful transfer of all the settings from the Prusa instance on the Pi3, I got another Pi Zero 2 W, which I am now trying to use for the Ender. (Call this Pi the 0E, for Zero Ender.) It is, as best I can tell, the same OctoPrint version as the 0P system. (I used the Raspberry Pi Imager, which downloaded the OctoPrint image for 0E. I did this less than a week after doing the same for the image in the 0P system. So it's possible 0P is a version older than 0E, but I doubt it. If anything, the 0E image is newer.)

I downloaded the backup from the Pi3 Ender instance of OctoPrint, the same way I did from the Prusa instance, and then I tried to restore it on the setup screen of the 0E system. I have tried this multiple times. Both backups have excluded timelapses and uploaded files. Both backup images are between 85k -95k in size. I have tried starting restoring the image to this 0E several times. I always get the modal window with the message, "Uploading backup, this can take a while. Please wait..." but it never changes. One time I let it run for about 3 hours and it never changed.

I did a new backup from the Ender and tried restoring that. Same thing. I tried restoring the Prusa backup image to the 0E system and the same thing happened. I burned a new image of OctoPrint on my MicroSD card and started all over again. Same thing with each test restore.

I'm having a supposedly unrelated problem: Whenever I connect with ssh, the connection always drops within 10 minutes. I've never had this issue before, but I'm mentioning it since I'm wondering if this could signify a problem with the Pi Zero 2 W's wifi connection or something like that.

Have you tried a different SD card?

Good thought - forgot to mention that. Yes, I have.

I'm beginning to wonder if this is just too much for a Pi Zero 2 W to handle or if I need to go through and disable plugins.

You may try just to save the plugins in the Backup, not the timelapses, to see if it work anyhow.

I excluded uploaded files and timelapses. Both plugins I'm testing are under 100k total size.

I'm checking another possibility right now and if it gives me the results I think I'll get, it puts the problem more in the Raspberry Pi hardware sector than in the OctoPrint software sector.

I was running a test during my last post. I connected PiB through an ethernet cable (and adapter) and loaded the OctoPrint web interface through that network connection instead of the wifi one. The backup loaded and I started seeing progress (with different messages) immediately.

At this point I'm beginning to suspect this Pi Zero 2 W has a bad wifi chip in it, but I'm not sure. I'm asking on the RasPi forum about it.

While I think it's quite possible there might be more insight on this thread (like stories from people with similar issues), I think this test makes it clear the issue has nothing to do with wifi and is clearly a hardware issue.

1 Like

Definitely a driver issue. Found this after a while:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.