Cannot set up C270 as second camera

Camera model

Logitech C270 - second camera added
Raspberry Pi Camera Module V3 - Default camera (connected to Classic Webcam) - This works

What is the problem?

Cannot get second webcam to function; "Webcam server is currently not running." Started getting that error after setting up the haproxy. Before that, was getting the generic Chrome ERR_CONNECTION_REFUSED message.

I recognize that this same question has been asked multiple times, but for the life of me I can't figure out what is going wrong, so it must be something stupid.

What did you already try to solve it?

Followed instructions from Setting up multiple webcams in OctoPi the right way.
Read through as many forum posts as I could find with the same issue. Watched a couple of videos that were linked in some of the forum posts.
During troubleshooting noticed that any of the updates that I put into the octopi.txt or webcam2.txt files are not being captured in the webcamd.log (example: still shows port for webcam2 as 8082, which I tried during troubleshooting, but current webcam2.txt has port as 8081)

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

webcamd[1].log (284.6 KB)
haproxy.log (130.8 KB) (818.5 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint 1.9.2
OctoPi 1.0.0 (build 2023.06.27.080047)
Printer is Ender 3 S1 firmware V3.0.4_C
PC trying to access stream is Windows 11, Chrome browser.

Gave up and reloaded Octopi with new camera stack.