Cannot update from 1.6.0 to 1.6.1

What is the problem?

Trying to update from 1.6.0 to 1.6.1. I get the message "The update did not finish successfully. Please consult octoprint.log and plugin_softwareupdate_console.log for details."

What did you already try to solve it?

I tried looking through the logs but I really don't know what I'm looking at. Restarted the pi, restarted octoprint, tried running in safe mode, nothing works.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!) (27.6 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint 1.6.0, Ender 3 Pro, Chrome, Windows 10

Here's the only log I could find. (17.1 KB)

Hmmm... Seems like you have some issues with your install generally. The update command is not producing any output, just failing, and there's a few errors that make it seem like something has gone sideways.

Try installing it using SSH, log into your Pi and execute this command:

~/oprint/bin/pip install --force-reinstall --no-cache-dir OctoPrint==1.6.1

It may take a while but that should sort some issues. If that command fails, then let us know any output you got from it.

Thank you so much for the advice. I gave that a shot, it seemed like it was going ok then I received the following:
[/quote]ERROR: Error [Errno 12] Cannot allocate memory while executing command python egg_info
ERROR: Could not install packages due to an EnvironmentError: [Errno 12] Cannot allocate memory

How much memory have you left?

You can find it at the end of the files sidebar

25.5GB left. Think thats plenty lol

That's disk.

@Adam_Zies-Way to check free mem execute free -mt via SSH. You'll need to do this when the issue arises.

pi@octopi:~ $ free -mt
              total        used        free      shared  buff/cache   available
Mem:            874          69         605          18         199         731
Swap:            99          37          62
Total:          974         107         667

Looks OK. Was this as the issue was occurring?

No that was with everything sitting, idling as it were. I ended up writing a new image to the SD and just redoing everything. After that the update went through without a problem. I really hate doing things that way, but it worked. Thank you for all your help.