Cannot Update to 1.5.3

What is the problem?

I am getting errors when trying to update to 1.5.3 from 1.4.0

What did you already try to solve it?

I have checked the octoprint.log and the plugin_softwareupdate_console.log

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

octoprint (2).log (21.2 KB) plugin_softwareupdate_console (1).log (196.2 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint 1.4.0
Version 0.17.0, running on Raspberry Pi 3 Model A Plus Rev 1.0
Printer Ender 5+ (Currently off, and disconnected to update.)
Chrome Browser on Windows 10 PC.

I saw something about it failing on PIP. I found that it is a built-in plug-in. I tried doing a cleanup on the plug-in, but no help.

We had that issue before but it's quite rare and we are not sure why it happens and what to do about it.

For now the easiest solution is to backup your Octoprint via the backup and restore function, flash a fresh image (maybe update to 0.18.0 while you're on it :slight_smile: ) and restore your backup