Cannot upload files


#1

What is the problem?
Tried to upload a file locally. It didn't work
Tried to update. Didn't work.

What did you already try to solve it?
Searched google. Found that the issue is the system date is wrong. Fixed it with sudo timedatectl set-ntp True. Now everything works. The problem is, how do I make it persistent after a reboot? I can figure out how to run the command at boot, but I can't find how to do it after it is connected to the wireless.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)
OctoPrint 1.3.7rc4
OctoPi 0.14.0
Prusa i3 mk2, 3.1.0 firmware
Log File


#2

It's probably a good idea to remote into your Raspberry Pi and run...

sudo raspi-config

Once there, make sure that the localization features are set, to include the timezone information.

This is the output from mine and I've never had to change anything (else) for my OctoPi 0.15.0 image.

$ timedatectl
      Local time: Fri 2018-05-11 13:40:06 PDT
  Universal time: Fri 2018-05-11 20:40:06 UTC
        RTC time: n/a
       Time zone: US/Pacific-New (PDT, -0700)
 Network time on: yes
NTP synchronized: yes
 RTC in local TZ: no

#3

I did that. Didn't help.

Now I am facing a new problem. Octopi decided to not connect to the wifi anymore... After tinkering with it for hours, I decided to reinstall OctoPi. Wifi still doesn't work. I'm going to try connecting through the LAN...


#4

Somewhere in the documentation for OctoPi involves editing the /boot/octopi-wpa-supplicant.txt file or similar.

Make sure to remember to go to the bottom of that file after adding your wifi stuff to change the country code.


#5

Yeah. Didn't forget about that. 8 am not sure if that was available in the version I was running, but I ended up reinstalling OctoPi and configuring everything again.

You can consider this case closed. Thanks for the help!