Cannot upload stl files from computer

What is the problem?

When I try to upload an .stl file, I'm unable to do so. I ope the finder module, drill down to the "files" folder where the .stl files are, and when I get there, the files are all "frozen" meaning clicking on them to upload them does nothing. I've tried dragging and dropping but that doesn't solve it.

What did you already try to solve it?

Drag and drop

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

octoprint.log (892.1 KB)
plugin_pluginmanager_console.log (118.2 KB)
plugin_softwareupdate_console.log (10.5 KB)
serial.log (148 Bytes)

Macbook Pro OS Big Sur 11.4 Latest stable version of Octoprint,


Hi. I did this when I first started...

Octoprint does not process .stl files. You need to process .stl files with another program (a "slicer") like Ultimaker Cura. That is what I am using. Cura "slices" the .stl 3D model and creates gcode commands that get stored in a .gcode file. Cura is an entirely different beast with hundreds of options.

This is what Octoprint needs. ".gcode" - not ".stl".

I hope this helps. Good luck.



Yes, that is helpful and makes sense. This is obviously my first attempt at using Octoprint. Everything just says to upload/drag-drop files into Octoprint, without mentioning to mutate them from .stl to gcode.

When we slice the .stl file in Cura, however, the only options are to upload them to the printer via USB or SD card. So, once they're sliced, how do I transfer them to the Octoprint queue since I'm now untethered from the printer? I am sorry to ask such rudimentary questions but I want to make sure I don't make things worse for myself by making false assumptions.

Glad to be of some help. I am only one week into this 3D printing thing.

In Cura, go to the Marketplace tab in the upper right of the screen and install the Octoprint plugin. This will give you an option in Cura to upload the .gcode directly to Octoprint after you slice a model. Alternatively, you can just save the .gcode file on your computer and upload via the Octoprint web browser. I am unsure what you mean by untethered. My Raspberry Pi is always connected to the printer via the USB cable.

No worries about newbie questions. Happy to help.


You're being super-helpful. I downloaded the plugin, and verified it's installed, and restarted Cura, but after slicing an stl file, the only option I'm given is to save it to disk. I may have to save it to my harddrive, then try to upload that gcode to Octoprint, which isn't really making that step of the process less involved.

What I meant by "untethered" is that I have a wireless dongle for my Pi. That's all. The Pi is connected by a USB to the printer, but I don't have to use a USB or SD to go back and forth between by laptop and printer anymore because of the Raspberry Pi.

Sorry - there are a few more steps with that plug-in.

Follow this guide:

WOW! That is so helpful - thank you so much. I would have never figured that out. THat just made things so much easier.

Happy to help! There is so many guides like this for newbies like us. Just google your way to success or ask a question on this forum. Some very nice people have dedicated huge chunks of their time for everyone to benefit. It is awesome.


1 Like