Cannot view Raspberry Pi stream after new router installed

Camera model

-Day/Night camera:

What is the problem?

Moved printer to a new network where webcam streaming was working. Before I could do a test print, the network had a modem/router change from Spectrum (listed at end). Now I'm able to connect to OctoPrint on my RaspPi comp and queue jobs. My webcam does not broadcast.

Error from http://(local ip)/webcam/?action=stream :

503 Service Unavailable
No server is available to handle this request. 

Error from (local IP)/#control :

Webcam stream not loaded

It might not be configured correctly or require authentication. You can change the URL of the stream under "Settings" > "Classic Webcam" > "Stream URL". If you don't have a webcam you can also just disable webcam support there.

Currently configured stream URL: /webcam/?action=stream

What did you already try to solve it?

  • Updated/upgraded/restarted Raspi comp
  • Ran "raspistill -o Desktop/image.jpg" which resulted in a picture from the webcam. So webcam is connected to Raspi comp
  • Confirmed Haproxy settings match the settings listed here for Raspbian 10 (Buster)
  • looked on forums for similar problem, could not find any.

Have you tried running in safe mode?


Did running in safe mode solve the problem?

No, webcam still not broadcasting

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

browser.user_agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:109.0) Gecko/20100101 Firefox/115.0
connectivity.connection_ok: True
connectivity.enabled: True True
connectivity.resolution_ok: True
env.hardware.cores: 4
env.hardware.freq: 1400.0
env.hardware.ram: 914006016
env.os.bits: 32 linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 3 Model B Plus Rev 1.3
env.plugins.pi_support.throttle_check_enabled: True
env.plugins.pi_support.throttle_check_functional: True
env.plugins.pi_support.throttle_state: 0x80000
env.python.pip: 22.2.1
env.python.version: 3.7.3
env.python.virtualenv: True unknown
octoprint.last_safe_mode.reason: unknown
octoprint.safe_mode: False
octoprint.version: 1.9.2
printer.firmware: Prusa-Firmware 3.11.0 based on Marlin
systeminfo.generated: 2023-08-22T06:56:53Z
systeminfo.generator: zipapi

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

-Raspberry Pi 3b+ rev 1.3
-Raspbian 10 (Buster)
-Day/Night camera:
-new Spectrum Router: SAX1V1K