Cannot zero Z-axis after upgrade 1.10.0

What is the problem?

After installing the 1.10.0 upgrade, my Z-axis will not work correctly. the z-offset parameter in the [bltouch] section pf printer.cfg has been commented out but the program, and when it thinks z is homed, it is actually about.1mm too high, and nothing sticks to the bed.

What did you already try to solve it?

Tried putting a z-offset in the slicer, but then the printer tries to move to a negative Z and crashes. Tried different tricks in the gcode, but my slicer has so many G92 codes it is useless.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!) (38.5 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint 1.10.0
Octopi 1.0.0
Browser Safari
Python 3.9.2 on Mac
Printer Creality Ender 4.2.7, Printhead Creality Sprite with BLTouch
Klipper on Raspberry Pi (Can't find version #)

The 1.10.0 update was for OctoPrint. Your 'printer.cfg' sounds like Klipper configuration, which is separate from OctoPrint and will not have been changed by updating OctoPrint.

It sounds like you need this z offset setting to correctly calibrate your printer, so that the BL touch knows how far away from the actual nozzle height it is. I'd suggest un-commenting it and setting it correctly. If you need more help with Klipper I'd suggest a Klipper forum as I don't know the details here.

Yes indeed.

I recommend to consult the Klipper forum:

Thanks, I'll check the Klipper forum. So things like Mxxx commands being deprecated is being done by Klipper, not Octoprint. Since I never interact with Klipper directly (except editing printer.conf) I just assumed it was the Octoprint update that was the culprit.

I appreciate the help.

1 Like