Can't access http://octopi.local on mobile phone web browser


#1

What is the problem?
Using my android phone + chrome, I go to webpage http://octopi.local results in error

What did you already try to solve it?
I know I can access via IP address
but want to know if there a way to access it using the domain name instead of the IP

or if I can change .local to something else that the mobile phone browser can open.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)


#2

short version, android chrome doesn't support it.


#3

What is the reason why it doesn't open .local domains?

Can I change the .local domain name to something else android chrome can open?

Or if there is a router based hack or something else to do so I don't need to use the IP address?

It is more preferable to use the domain name since IP can change and I just need to bookmark one domain name etc..


#4

Read the link; it's because octopi.local isn't a real dns entry. It's sort of an agreement between devices that hasn't made it to all operating systems.

You can set your octopi instance to have a static IP, for one.


#5

yeah I read some of the stuff in the link you posted
but your explanation is more simple to understand.

So basically I can only do is wait/provide feedback for Android OS to implement this feature?

Yeah I know about setting a static IP for the octopi
but I was wondering if we can pair that IP with a domain name in the router?

In the router, there is the static lease section which has a hostname (we can input a name)..
So can I make that hostname accessible by the webpage instead of the static IP?


#6

You could purchase a domain name like mydomain.com, issue a DNS A record of octopi to that with your private IP address and then use your Android's browser to surf over to http://octopi.mydomain.com . I know, way expensive.

Or just http://192.168.1.15/ or whatever.