Can't access my Creality using Octoprint

I have been using my Octoprint to my Creality 10 Max for some years without any problem. Today then I start the printer up Octoprint can't connect. The printer starts fine and Ocroprint too, but then I click "Connection" in Octoprint I got this error:

Changing monitoring state from "Offline" to "Detecting serial connection"
Performing autodetection with 0 port/baudrate candidates:
Changing monitoring state from "Detecting serial connection" to "Error"
Changing monitoring state from "Error" to "Offline after error"

I have tried to restart both printer and Octoprint several time. Also have restarted in safe mode from Octprint but same issue. Before printer always restarted then I attached the cable between Octoprint and printer, but not now.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/92.0.4515.131 Safari/537.36
connectivity.connection_ok: false
connectivity.enabled: true false
connectivity.resolution_ok: false
env.hardware.cores: 4
env.hardware.freq: 1500
env.hardware.ram: 1979641856
env.os.bits: 32 linux
env.os.platform: linux2
env.plugins.pi_support.model: Raspberry Pi 4 Model B Rev 1.1
env.plugins.pi_support.octopi_version: 0.17.0
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 19.3.1
env.python.version: 2.7.16
env.python.virtualenv: true
octoprint.safe_mode: false
octoprint.version: 1.6.1
systeminfo.generator: systemapi

0 ports to use means that the Pi is not seeing any printers connected that it can communicate to. We can't say why this is without some more testing, so here's some things for you to try:

  • Try a different USB cable/port combination
  • If you have taped the 5V pin of the USB cable, check it has not been dislodged.
  • Run lsusb over SSH to see if there's any devices reported that look like a printer
  • Run dmseg -w dmesg -w, to watch the system logs. Then unplug and plug in the printer. You should see some log messages relating to a new USB device and hopefully no errors. You can paste the new output here if you want someone to check it.

there is a typo, that should be dmesg -w

1 Like

I changed the USB-port and that solved the problem. :slight_smile:

1 Like