Cant access Octoprint through ssh after reinstalling image

New to Pi & Octoprint so please excuse any inaccurate terminology.
Windows 10
RasPi 3b+ (Rev3)
Genuine SanDisk Ultra 64gb
Ender 3 Max

A brief description of my issue(s) is;
I downloaded & installed Octoprint yesterday, flashed it with Balena on to a genuine 64gb SanDisk Ultra and followed the steps to get it up and running, up to and including changing the host name & password and logging into the Octoprint dashboard through the new host name. I had no issues with these steps but I noticed that Octoprint wasn’t recognising my printer or saving my printer settings. When i went into the printer settings to see why not and add a print profile for the Ender 3 Max it wouldn't save and just reverted back to the Default printer.
I did a bit of research as to why this might be happening on the forum and I did try rebooting in safe mode to see if that would help the printer issue beforehand, as i noticed that the safe mode was marked as false, but it didn't make any difference. A couple of answers suggested that the SD card might have been the issue. Therefore, today I took the SD card out, deleted everything, reformatted it to FAT32 again in case there was something left on there that i couldn't see and restarted the whole process with a fresh download of the image. I uncommented the 4 lines on 27, 28, 29 & 30, and added my SSID & password on 28 & 29 using notepad++ as i had done previously and saved before exiting, but now when try to access it through the command ssh pi@octopi.local I get the message below. I've tried to give as much information as i can but if ive missed anything please let me know.

H:>ssh pi@octopi.local
The ECDSA host key for octopi.local has changed,
and the key for the corresponding IP address fe80::f398:9c32:b896:6125%26
is unknown. This could either mean that
DNS SPOOFING is happening or the IP address for the host
and its host key have changed at the same time.
Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that a host key has just been changed.
The fingerprint for the ECDSA key sent by the remote host is
Please contact your system administrator.
Add correct host key in C:\Users\SSmith/.ssh/known_hosts to get rid of this message.
Offending ECDSA key in C:\Users\SSmith/.ssh/known_hosts:1
ECDSA host key for octopi.local has changed and you have requested strict checking.
Host key verification failed.

I noticed that the state of the WIFI has been asked on other posts, so for information I'm getting 23-25mb from my laptop that is approx. 2m from my pi. and the router is on the floor below in the opposite corner.

That means at some point you already had another Pi flashed with OctoPi and connected through SSH to it, and now SSH is warning you that the other side has changed its host key (because you flashed a new OS) and refuses to connect because it could be an attack. It usually isn't though and you just need to remove the offending key to continue. Read this post for example:

Ive never had Pi or Octoprint before but i'm assuming that by me wiping everything & starting again, this is what its recognising? Ill have a read through the post you've shared and see if i can figure it out from there how to remove a host key.. As i say, noob issues. Thanks a lot for taking the time to respond.

Hey Foosel.

Excuse my ignorance but as i say im currently 24hrs into anything even closely resembling "coding" experience. The example that El Bruno uses in his post is

This is a very common scenario, and because I forgot how to fix it, I’ll write the simple command remove all keys belonging to the IP / hostname from the known_hosts file.
# ssh-keygen -R <host>
ssh-keygen -R
And that’s it, keys removed and now I can connect via SSH

I'm sure this is achingly simple for most of the people on here but i dont want to go button bashing without understanding what i'm doing. Do i take from the above that i would type those two lines into my windows command bar and replace with octopi, and the IP address with my own? Do i have to retain the < > either side of host?


I simply deleted the 'known host' file from the .ssh folder in C:Users/My username/.ssh and it has allowed me to continue. Thanks again. I hope this helps with the original issue of not recognising the printer.

Hello, I am having this issue this issue with my Octopi. i have deleted the known host file and it worked for a while and now it doesn't. I get this error on any computer in my house. I was wondering if may the router might somehow store this info?

Thank you

PS C:\WINDOWS\system32> ssh pi@octopi.local
The authenticity of host 'octopi.local (2600:6c4e:b3f:3ddd:bdb6:7edc:78ab:6a7)' can't be established.
ECDSA key fingerprint is SHA256:YYyPMYOpLX0KXzibCTjP2Jyh3E1qtf1n2GqoNwJ2Pg0.
Are you sure you want to continue connecting (yes/no/[fingerprint])? yes
Warning: Permanently added 'octopi.local,2600:6c4e:b3f:3ddd:bdb6:7edc:78ab:6a7' (ECDSA) to the list of known hosts.
pi@octopi.local: Permission denied (publickey).