Can't access Octoprint with either IP or Hostname

I have Octoprint installed on a Linux computer and upuntil today when I had to factory reset my router, I had no issues access it via a browser on my windows PC. Since resetting my router, I am no longer able to connect to Octoprint from my windows PC, whether by using it's IP address or the octoprint.local hostname.

I have verified that the Octoprint PC is connected to the internet and Octoprint is started and running (using the host name in a browser on the linux PC brings up Octoprint with no problems).

ping linPcIP works from a windows terminal
ssh linPcIP works from a windows terminal
http://linPcIP in the browser's address-line fails with an ERR_CONNECTION_TIMED_OUT error.

Not sure what else to check or what logs there might be. Let me know what you need from me and I'll do my best to provide it.

Hello Tim,

to rephrase your description:

ping linPcIP from a shell works
ssh linPcIP from a shell works
http://linPcIP in the browser's address-line fails.

What error / message does it give you?

Hi Planetar,

That is correct. I get the generic chrome '"[Preformatted text](http://linPcIP)" can't be reached, more specifically the timed out error ERR_CONNECTION_TIMED_OUT.

I suppose you tried it on a different browser so anything browser-specific can be ruled out?
The next place I'd look are the network and firewall settings of the router. Is there anything that 'protects' the IP range your linux box is in? Guest network or some such?

I've tried in Chrome and Firefox, same issue. I don't currently have the guest network activated or setup. The only thing I did in the router was to reserve it's IP address, thus making it a static IP. Everything else is factory stock in the Router.

You may connect an HDMI TV/monitor to the Pi to see what's going on during the boot process.

I have a monitor attached to the Linux computer that I can look at logs and everything. Anything I should be looking for in particular? the PC has internet access, and is able to access my Octoprint instance on the machine, using both IP and Host name.

Sorry, forgot, you do it a different way...

Being able to access octoPrint locally (from the linux box itself) says the problem is not there.
Being able to ping, ssh the linux box from your win box says the networking basically works. But apparently something blocks access to port 80.
Windows firewall? Some redirect? Proxy settings?

(Sort of a wild idea but you might even try to bind haproxy frontend public to another port, say 8888 to check on that)

I'll see if I get some time tonight to change the port to 8888 and see what that does. I'll report back with any findings.

I don't think it's a Windows firewall issue, as my phone can't get to it either when I type in the IP address. The other two things I'm not sure how to check.

I have updated the haproxy config file and set the binding for the frontend from 80 to 8888, restarted the computer, but no change unfortunately.