Can't access over local network

I have problems accessing octoprint.
When I connect a Monitor to the Raspberry PI it prints the IP-adress, if I enter http://octopi.local or the IP-adress in a browser, it shows "the website isn't available". When I go to the router settings the Octopi is shown with the same IP-adress. I also done a ping command, scanned the networks and the show IP-adress command, all worked. I followed the troubleshooting guide but it still won't work.
Im using an Raspberry Pi 3A+ and flashed the SD-card with the offical imager and for testing with etcher in general I edited the "octopi-wpa-supplicant.txt" file with VS-code.


Your title is "can't access over internet" - but do you mean on your home network? Just to clarify that OctoPrint is not accessible from the internet normally, to access it's IP address you must be connected to the same network.

Are you able to use SSH to get into the console of the Pi? Trying to work out if it is just the UI that's not available, since it sounds like it is connected to your network fine.

SSH doesn't work too.

Please give us some details about your local (home) network. You probably have a modem/router (either one device or two). You may also have WiFi from some device.

You have said you have a Raspberry Pi but how does it connect to your network? Tell us about other devices you wish to use to communicate with your RPi, how they are connected, and what operating systems they run.

Once we have this information, we can provide you with some more detailed instructions like commands to run on each device to gather additional troubleshooting information.

The more details you provide, the better help we can provide.

My Raspberry PI is connected to the router via WiFi I also tried an USB-LAN adapter. The router works fine and shows the device "octopi" and it's IP-adress. I'm using an Windows 11 PC with Google Chrome to communicate with the octopi.

You said you have a monitor connected to the RPi and have the IP address. What is that address (it is local to you so you don't need to obfuscate it). How is the Windows 11 PC connected to your network? On your Windows 11 PC, please open a command prompt and give us the output of ipconfig /all, route print, and nslookup octopi. Please use the </> icon above to keep the output from being mangled by the markdown.

You said SSH failed. What is the output when you type ssh pi@octopi or ssh pi@IP-address? You can also use PuTTY (and WinSCP once we get SSH working).

Some routers are configured to have a guest WiFi in addition to the regular WiFi. If the RPi is connected to this guest WiFi network, it may be blocked from traffic on the LAN or regular WiFi (and traffic from other connections to the guest WiFi.

I changed the title because internet access isn't at issue here.


first thanks for your help.
The IP-address is
The output of the Windows comand prompt:
Connectionspecific DNS-Suffix:
Description. . . . . . . . . . . : Intel(R) Wireless-AC 9560 160MHz
DHCP activated. . . . . . . . . . : Yes
Autoconfiguration activated . . . : Yes
IPv4-Address . . . . . . . . . . :
Subnetmask . . . . . . . . . . :
Standardgateway . . . . . . . . . :
DHCP-Server . . . . . . . . . . . :
DNS-Server . . . . . . . . . . . :
The Putty output is:
Connection failed. FlowSocketConnector: Failed to connect to target address.
Windows error 10060
I'm connected with the same Wifi on my PC.

I believe this is a Windows 11 Firewall issue but I can't duplicate it here on a Windows 11 system.

If you open a command prompt and type ssh pi@octopi what error message do you get?

You might try googling the error messages you get. Add "Windows 11" to further refine the search(es).

The response to the Windows ssh comand is ssh: connect to host octopi port 22: Connection timed out.
I haven't found a solution to fix this issue, but I don't think its platform related cause when using the termius android app(connected to the same Network) I couldn't establish a connection and get the error message host is unreachable.

Looks like in addition to the monitor, you need to find a keyboard to connect to your Raspberry Pi. You should be able to login using the username pi and its password. Please provide the output of netstat -lnt (lowercase L). If your RPi isn't listening on port 22 (see below), then create an empty file named /boot/ssh and reboot the RPi. My output is below:

pi@octopi:~ $ netstat -lnt
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State
tcp        0      0*               LISTEN
tcp        0      0*               LISTEN
tcp        0      0    *               LISTEN
tcp        0      0*               LISTEN
tcp6       0      0 :::80                   :::*                    LISTEN
tcp6       0      0 :::22                   :::*                    LISTEN
tcp6       0      0 :::443                  :::*                    LISTEN

You can get more information from sudo netstat -auntp

If you can't find a keyboard, move the microSD card to your Windows 11 system. The /boot partition should mount and you can create the empty file named ssh using any text editor.

The output of the netstat-lnt looks the same like yours. But when I create the ssh file and reboot, the file doesn't exist anymore.

If you have the line tcp 0 0* LISTEN then the SSH server is running.

The file /boot/ssh is just a marker to tell the system to configure the SSH server to start when the system is started. That only needs to be done once and from the netstat output, it has done its job.

Since both Windows and Termius can't connect to the RPi, I believe that points to either the RPi or the router as the cause of the issue. Since you now have a monitor and a keyboard attached to the RPi, let's look at the output of more commands on the RPi. ifconfig, route, arp, ping, traceroute If traceroute isn't found, you may need to install it with sudo apt-get install traceroute.

Getting the output of these commands to us is going to be painful. At this point, taking photos of the monitor with a camera may be the only option.

You shoud connect with:

The browser gives the error message "not available" and ssh doesn't connect too.

From the information you have supplied, it appears that the network is configured properly, the RPi has internet connectivity, and is in the same netblock as the Windows 11 PC (and the Termius Android application).

From the RPi, what does ping return?
From the Windows 11 PC, what does ping return?

I believe that the router is to blame for this. I believe that the WiFi is configured to prevent connected devices from communicating with each other. This is often the default configuration of a "guest" network. We may need some screenshots of the router's web interface if you can't figure it out on your own.

1 Like

Both ping commands on PC and RPi return, that the destination host is unreachable.

I am 99+% sure its the router. What model do you have? Can you connect to the router's web UI?