Can't centre print on bed

Hi,

I am a complete noob in 3D printing so I’m putting that out there straight away.

I’m using a Creality CR-6 SE with Octoprint

I’m running OctoPrint 1.4.2 and OctoPi 0.17.0 on a Raspberry PI.

My problem is that when I start a print through Octoprint it always starts right at the front of the bed on the left-hand side not in the centre. However, if I start a print using the touch screen and load the gcode from the SD card then its centred correctly.

So, its obviously something I’ve done wrong with the setup of Octoprint.

I followed this youtube video to set up cura and import the ini config as directed and it all went well.

https://www.youtube.com/watch?v=0I_BIR36Grk&ab_channel=TeachingTech

Importing the STL file in through Octoprint works and the print comes out fine but I’m stuck on how to get the print to start in the middle of the bed. And if I view the loaded print through the Gcode viewer its centred just not on the bed.

Oh, one last point that could be important is that when the extruder moves all the way over to the left theres a grinding noise like its trying to go even farther then its limits allow, not good.

If the way I’m doing this is outdated and theres a better way to get STL to gcode and print them centred on the bed through Octoprint then I’m all ears.

Thanks in advance for any help.

octoprint.log (42.0 KB)
plugin_PrintTimeGenius_engine.log (13.3 KB)
serial.log (148 Bytes)

The most used "source code" for 3D prints is an .stl file. This file is input to a slicer that produces .gcode output. This .gcode file is processed by the firmware in the printer (most often Marlin or a derivative).

While it is possible to configure a slicer that runs on the RPi (and can therefore be used by OctoPrint when it encounters an .stl file), this is not the recommended solution. The cura engine that is available is very old and making changes to the profile (which is probably where this problem resides) is difficult.

Most modern slicers have a graphical user interface and run on a desktop/laptop computer. You have access to a plethora of adjustments including predefined printer profiles, material profiles, quality settings, etc.

I'm pretty sure you are not using a slicer on the RPi to generate the gcode files that you are putting directly on the Creality SD card.

Perhaps if you give us more detailed information about your workflow, we can better help solve your problem.

BTW, the serial.log needs to be enabled before it is useful to us. Use the blue link for instructions on how to do that.

Ok I've now ditched that setup and did some more googling, downloaded Creality Slicer 4.2, I see your point about using a GUI so I'll have a crack and see how this setup goes. Thanks for your help.

The saga continues…

I have now updated to a raspberry pi 4b not that I thought this could be the problem but my old 2 just wasn’t fast enough.

I’ve started from scratch with octopi even downloading the image again.

Installation went well without any problems.

Installed these plugins…

Creality-2x-temperature-reporting-fix (0.0.4)

Dashboard (1.16.3)

Detailed Progress (0.2.6)

DisplayLayerProgress Plugin (1.24.0)

Floating Navbar (0.3.4)

Installed Creality Slicer 4.2 and setup my Creality CR-6 SE

Capture

As you can’t read the start and end G-code there here it is.

Start G-code

M201 X500.00 Y500.00 Z100.00 E5000.00 ;Setup machine max acceleration

M203 X500.00 Y500.00 Z10.00 E50.00 ;Setup machine max feedrate

M204 P500.00 R1000.00 T500.00 ;Setup Print/Retract/Travel acceleration

M205 X8.00 Y8.00 Z0.40 E5.00 ;Setup Jerk

M220 S100 ;Reset Feedrate

M221 S100 ;Reset Flowrate

G28 ;Home

G92 E0 ;Reset Extruder

G1 Z2.0 F3000 ;Move Z Axis up

G1 X10.1 Y20 Z0.28 F5000.0 ;Move to start position

G1 X10.1 Y200.0 Z0.28 F1500.0 E15 ;Draw the first line

G1 X10.4 Y200.0 Z0.28 F5000.0 ;Move to side a little

G1 X10.4 Y20 Z0.28 F1500.0 E30 ;Draw the second line

G92 E0 ;Reset Extruder

G1 Z2.0 F3000 ;Move Z Axis up

End G-code

G91 ;Relative positionning

G1 E-2 F2700 ;Retract a bit

G1 E-2 Z0.2 F2400 ;Retract and raise Z

G1 X5 Y5 F3000 ;Wipe out

G1 Z10 ;Raise Z more

G90 ;Absolute positionning

G1 X0 Y{machine_depth} ;Present print

M106 S0 ;Turn-off fan

M104 S0 ;Turn-off hotend

M140 S0 ;Turn-off bed

M84 X Y E ;Disable all steppers but Z

Capture1

I’ve pretty much left all other setting in Creality Slicer alone for the time being, well until I understand things a little better and know what I’m doing.

I then load this STL file:

infill_25mm_cube.stl (684 Bytes)

And save it back as a gcode file to my HD, then upload it to the raspberry pi so Octoprint can do its thing.

CCR6_infill_25mm_cube.gcode (254.5 KB)

Hit the Upload button (not the upload to SD) and transfer this file to the raspberry pi.

I then get this error which wasn’t happening before so its new

Object doesn't fit print volume

Object in CCR6_infill_25mm_cube.gcode exceeds the print volume of the currently selected printer profile, be careful when printing this

Hit the gcode viewer and the model is dead centre on the bed.

I start the print the extruder moves to the centre touches the bed, draws two lines down the left hand side of the bed (I think its 2) then moves the bed as far back as it will go moves the extruder over to the left making a horrible grinding noise and starts printing in the bottom left hand corner again just as it did before.

What am I doing wrong, this is a new raspberry pi, new power supply and a new USB cable with a new install of Octopi downloaded fresh from octoprint.org/download/

If its something I’ve done then I have made the same mistake twice and I was very careful while setting this up for the second time.

Heres all the logs from this print
octoprint.log (156.7 KB)
plugin_pluginmanager_console.log (57.8 KB)
plugin_softwareupdate_console.log (20.5 KB)
serial.log (217.7 KB)

Thanks in advance for any help.

Whatever your slicer is doing there, it's wrong:

image

This is your model, with the visited and printed bounding boxes enabled (red and blue outlines - meaning the coordinates actually contained in the GCODE file without and with extrusion).

Your slicer is assuming your printer's origin to be in the center of the bed. As far as I know, for the CR6 this is not the case and it's lower left. So untick that checkbox there, it's wrong like this. Also these lines in your start GCODE:

G1 X10.1 Y20 Z0.28 F5000.0 ;Move to start position

G1 X10.1 Y200.0 Z0.28 F1500.0 E15 ;Draw the first line

G1 X10.4 Y200.0 Z0.28 F5000.0 ;Move to side a little

G1 X10.4 Y20 Z0.28 F1500.0 E30 ;Draw the second line

look very fishy. I don't know where you got them from, but that's what makes your print head move all the way back. Rethink those lines/look for another profile to copy. Then reslice and try again.

tldr Your slicer is misconfigured. This has nothing to do with OctoPrint.

1 Like

Agree to @foosel :

grafik

You usually have Origin at Center only on Delta Printers.
Cartesian printer have one of the corners.
Try with that tick mark off.

Just checked with Cura and the profiles for MK2.5 and T-Rex 3

If you go to the Creality download page, the descriptions all say for Windows only, on a Mac download Ultimaker Cura.

Given Creality's reputation for "adding bugs" to Marlin firmware and the fact that the Windows version of Ultimaker Cura has support for almost all of the Creality printers (including yours), I think I'd delete the Creality Slicer and just use the real thing!

Not to mention that it looks like Creality Slicer is based on Ultimaker Cura 4.2 and Ultimaker is now on version 4.8.

.

2 Likes

Hello again,

I have now completely removed the creality software and install Ultimaker Cura 4.8 and also removed the "fishy" gcode lines and unchecked the centre bed option as well. And now I get this...

To make sure it wasn't this computer that was giving me the trouble I setup Ultimaker Cura 4.8 in windows 8.1 on a virtual machine and it still gives me the same problem when I slice whatever STL file.

While I understand this isn't a octoprint problem if anyone has any other forums where I should be trying to get help on this then I'm all ears.

thanks for the help

Also, could this be the printer itself as in a hardware problem?

But like I have said before I don't have this problem when printing the test files that came with the printer on the SD card

I'm at a complete loss here

Now you have misconfigured your printer profile in OctoPrint and told THAT that the origin is at the bed center. That's also wrong.

Nothing should say "origin at center" with your printer. Its origin is at the lower left corner, so don't configure anything but this in slicer or OctoPrint.

I haven't set the origin at centre in the machine settings I turned it off like people said to.

I'm talking about this in OctoPrint:

In your screenshot it clearly shows that the origin (the little grey circle) is considered in the center of the bed. That's wrong. You need to fix your printer profile in OctoPrint too, so that the gcode preview matches your printer.

Both the slicer and the printer profile need to be configured correctly so that stuff looks right.

1 Like

Thank you foosel, that was the problem and its now printing where it should be.

As I said before I am complete new to this stuff and its a learning process for me.

Thank you once again!