Can't configure keyboard to be US

What is the problem?

I am unable to configure my keyboard to be US settings. For instance, in order to get the @ char I have to hit Shift+' right now. And I can't find the | keystroke at all so that prevents me from trying some command lines to fix this. I am using Octoprint 1.4.2 with a Raspberry Pi 4 and have configured country=US in octopi-wpa-supplicant.txt (see below). I have an Ender 3 v2 (not that that is the issue here). I am new to Linux and Octoprint, and I have exhausted the steps I have run across in other discussions.

I am hoping someone can provide or point me to exact steps for how I can change the keyboard to be a US layout.

Thank you for the help.

What did you already try to solve it?

I've looked through the Octoprint forums and haven't been able to get any suggestions to work. I also haven't seen this exact issue mentioned in the discussions.

Complete Logs

Renamed the supplicant file to .log so that I could upload it as a file:
octopi-wpa-supplicant.log (1.8 KB) octoprint (2).log (95.4 KB) serial (1).log (266.9 KB)

You have to login to the Pi via SSH or you connect a monitor and a keyboard to your Pi.

There you have access to raspi-config where you can change the localisation:

1 Like

Thank you! For completeness in this thread, I had to run

sudo raspi-config

to get access to the settings. Hope this helps other complete newbies like myself!

1 Like

Yes, as it is described in the link. :+1:

1 Like