Can't Connect All of a Sudden

I've been using OctoPrint for about a week with no problems. Then, right after finishing a print I wasn't able to connect to my printer. When I try to, I get an error saying: "Refused to connect"

Thanks for any help!

What did you already try to solve it?

  • Checked cables
  • Made sure the printer is showing up in Device Manager - it is
  • Reinstalled Windows
  • Reinstalled OctoPrint, using Windows installer. Up to the point where I enter (my ip):5000 but that's where I get the error.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle (17.5 KB)

Additional information about your setup

Octoprint Version

Elegoo Neptune 3 Pro

Printer Firmware

Printer UI Version


System Manufacturer ASUSTeK COMPUTER INC.
System Model VivoBook_ASUS Laptop E210MA_L210MA
System Type x64-based PC
System SKU
Processor Intel(R) Celeron(R) N4020 CPU @ 1.10GHz, 1101 Mhz, 2 Core(s), 2 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. E210MA.306, 10/29/2020
SMBIOS Version 3.2
Embedded Controller Version 255.255
BaseBoard Manufacturer ASUSTeK COMPUTER INC.
BaseBoard Product E210MA
Installed Physical Memory (RAM) 4.00 GB

Microsoft Edge - Version 113.0.1774.57 (Official build) (64-bit)

Operating System:
Windows 11

I assigned the computer my printer a static IP but that didn't solve it. I ran windows network diagnostic and it gave me this:


I just can't think of why it wouldn't be connecting all of a sudden... :confused:


I'm a bit confused what the issue is right now. Do you have issues to connect to the OctoPrint webui or connecting to the printer itself when you're logged in on the OctoPrint webui?

Hi again :slight_smile:

Yes I have trouble accessing the OctoPrint web UI. After using the Windows installer when I try to access the Web UI it is giving the error messages.

Are you trying to access it on the same device?
If yes try http://localhost:5000 or in the browser

Yes using the same device. Both gave me the error: "ERR_CONNECTION_REFUSED"

could you check if the OctoPrint service is running?
I don't know the exact name of the service, but I'm pretty sure it got OctoPrint in the name :smiley:

Press the Windows + R keys on your keyboard to open the Run window. Type services.msc and hit Enter

It looks like it is running, I see "OctoPrint on Port 5000" running, "Startup type: Automatic"

since I'm not entirely sure what happened and where to find the logs for this instance I'm tagging @jneilliii
it's weird that it doesn't work even when you reinstalled Windows.

Yeah, re-running the installer will only allow for adding instances unfortunately as it tracks the previously used ports both in the registry and running services/used ports. If defaults were used during the install the logs can be found in C:\OctoPrint\basedir\5000.

EDIT: The provided system info bundle from the original post appears to be from a pi...

Hi jneilliii, thanks for helping me find the logs folder, here's what I found in there: (646.1 KB)

Yeah, looks like a botched install/upgrade. Was this running 1.8.7 and upgraded to 1.9.0? I know windows can have problems with this process because the files get locked and can't be overwritten while octoprint service is running. Have been meaning to figure out a way to easily do this with upgrade patch installs, but just haven't had the time. Best bet would be to try to manually force a reinstall of OctoPrint. In order to do that you should be able to stop the service in service manager of windows and then open a command prompt as administrator and run this command.

C:\OctoPrint\WPy64-31050\Scripts\python.bat -m pip install --force-reinstall --no-cache-dir octoprint

once that install finishes then start the service back up and see if the logs are still complaining.

I just ran through the process myself at work and that does work, but did throw an error for one of the modules because of missing MS Visual C++ build tools missing. You should be able to install those if you don't already have them installed (also required for OctoLapse plugin and I think PrintTimeGenius maybe.

select โ€œDesktop development with C++โ€, making sure these options specifically are enabled.

Ok, I stopped the OctoPrint Service and ran the command you gave. It looked successful until the end as it gave me messages like "Legacy Install Error" and "Failed building wheel for netifaces".

I've copied what I got into the attached file.

Afterwards I installed the MS Visual C++ build tools.

Thanks again for your insight!

Command (4.4 KB)

yeah, that's the error I was referring to. Once you have the MS Visual C++ build tools installed that command should complete without errors.

I'm verifying now on my work computer, waiting for build tools to finish up now.

confirmed the install completed without errors once I had the C++ build tools installed.

Wow. That did it. I'm able to connect to the OctoPrint UI now. Thanks so much, can I buy you a coffee?

Also in the future, what should I do when a new update comes out?

great, glad to hear. the best way would be to ignore the update within octoprint's web interface itself and use the following command to upgrade after stopping the service.

C:\OctoPrint\WPy64-31050\Scripts\python.bat -m pip install --upgrade octoprint
1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.