Can't connect Ender 3 V2 to Ubuntu

What is the problem?

Hi All!
I need help to connect my Ender 3 V2 to Ubuntu 21.04. The USB port seems ok (i can see the printer connected), but it seems that Octoprint don't have enought authority to connect (we can see it on octoprint log)

What did you already try to solve it?

i tried severals solutions provided by this board (thanks for the help!!).

  • Add authority to my user profile using the following commands:
    sudo chmod a+wr /dev/ttyUSB0

  • And try to add my user profil to the group dialout :
    sudo usermod -a -G dialout $USER

  • Change the USB cable

Have you tried running in safe mode?

Yes, but no changes

Did running in safe mode solve the problem?


Systeminfo Bundle

octoprint.log (111.7 KB)
serial.log (1.7 KB)

Additional information about your setup

OctoPrint Version 1.4.0, Printer : Ender 3 V2, System : Ubuntu 20.04

Again, thanks for your help!

Installing OctoPrint through snap is well known to have issues with permissions, it is not an official distribution and I have no idea who maintains it - it also seems to be outdated, since you have installed 1.4.0 which is 18 months old now.

Don't use the snap distribution, and install it manually yourself using this guide:

It is directed at a Raspberry Pi, but it is applicable for ubuntu as well with a few changes eg. changing some paths relevant to your user in commands etc.

1 Like