Can't connect Ender 3 V3 SE through working USB cable

What is the problem?

Hello, I have been trying to connect to my Ender 3 V3 SE whith USB through octprint and I've been having a headache trying to do it.

What did you already try to solve it?

I have already tried to install octoprint standalone and I am now trying on Docker. Octoprint recognizes the USB prorts but doesn't see the actual printer. I have already checked this cable as I was able to control the printer through Cura on my computer.

Systeminfo Bundle (15.1 KB)

Additional information about your setup

Since you are using Docker, have you passed through the usb device from your host to the container properly?

I think so as shown below
Screenshot 2023-12-31 003616

This is not what I mean. When you setup the container, you either need to use docker-compose and add your device there, or you add it as part of your command line when running the container.

I just used docker compose with the included script, did I miss something ?

In the docker-compose.yml file, you need to add the devices section and map your printer's connection to the container.

If you aren't generally familiar with how this works, I'd recommend sticking to a normal install - especially if that didn't work, it's going to be harder for you to debug connection issues as you've introduced an extra layer.

If you’re able to tell me easily how I can set that up I’m willing to search for things around. Otherwise, I’ll just get a seperate pi to take care of Octoprint later.

version: '2.4'

    image: octoprint/octoprint
    restart: unless-stopped
      - 80:80
    # devices:
    # use `python -m` to see what the name is of the printer, this requires pyserial
    #  - /dev/ttyACM0:/dev/ttyACM0
    #  - /dev/video0:/dev/video0
     - octoprint:/octoprint
    # uncomment the lines below to ensure camera streaming is enabled when
    # you add a video device
  # uncomment if you wish to edit the configuration files of octoprint
  # refer to docs on configuration editing for more information

  #  image: linuxserver/code-server
  #  ports:
  #    - 8443:8443
  #  depends_on:
  #    - octoprint
  #  restart: unless-stopped
  #  environment:
  #    - PUID=0
  #    - PGID=0
  #    - TZ=America/Chicago
  #  volumes:
  #    - octoprint:/octoprint


Here's an example of the compose file

If you don't know the path of your printer just run dmesg -w and unplug and replug them.
Then you should see the path in the dmesg output

edit: doesn't work for the cam - but the path for the cam should be /dev/video0 anyway

Thank you, I will try that in the next hours.