Can't connect PC to Raspberry, restarting PC works for a few minutes

What is the problem?

Raspberry Pi 4B running current OctoPrint won't stay connected to my computer. Restarting my PC lets me connect again for about a minute.

What did you already try to solve it?

I've done a good amount problem solving to get it as good as this. My Raspberry is plugged into a recommended power supply. I've swapped cables over and over to find one that allows me to pass data from my Raspberry to the 3D printer (Ender 3 V2), now found one that works. Restarting the Raspberry doesn't work. Restarting the printer doesn't work. Disconnecting the printer doesn't work. Restarting everything in different orders doesn't work. Keeping the printer plugged in, or keeping it unplugged through the various processes of restarting everything doesn't help.
Right after restarting the PC, I can find the Raspberry through octopi.local, and for the short time (a few minutes) it is working, everything seems to work.

Have you tried running in safe mode?

No. Also, I don't know how without being able to connect to the Pi for longer.

Hello @krishj39 !

Have you considered to use another browser?

Also you may have issues with the network.

You connect the Pi to an HDMI monitor/TV. At the end of the startup sequence you should get the actual IP address of the Pi.

Yes, I've tried other browsers. I was using Chrome and then also tried Firefox.

I got an adaptor today to be able to view the Pi directly through HDMI. I'll connect it when I get home.

Would using the direct IP address be likely to be more stable?

Not more stable, but more unique

At least it would indicate that this is not a routing problem, and rather a problem with mDNS/ZeroConf/Bonjour, so the discovery plugin.

Ok, I've tried lots of things but nothing has fixed the problem.

  1. I got the Pi on it's own monitor, confirmed it was loading properly and got the IP address.

  2. I can't connect using that IP address at all. Not for a moment.

  3. Connecting via octopi.local still works for max of a few minutes after restarting my PC.

  4. 've tried on a different network with the same results.

  5. Biggest progress! I accessed octopi.local on a different PC, and it seems to work normally.

Bottom line, I've narrowed the problem to my PC. Are there setting on my PC that could be blocking access that might not take effect for a few minutes after a restart?