Can't Connect to Ender 3 Pro with octoprint

What is the problem?

Can't connect to printer over octoprint. Gives error: Offline (Error: SerialException: 'device reports readiness to read but returned no data (device disconnected or multiple access on port?)' @ comm.py:_readline:2916 also subsequent error after attempting again: Error: No more candidates to test, and no working port/baudrate combination detected.

Printer will freeze and prints will fail if I try to do anything with octopi other than have it watch via the camera.

What did you already try to solve it?

  1. Replaced USB cord
  2. Replaced Power supply
  3. Restarted pi
  4. Restarted printer
  5. Manually selected baudrates.

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

octoprint.log (95.4 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint version: 1.4.2
Rasperry pi 3B v1.2
Firmware - TH3D studio firmware: U2.R1.B3 Marlin Firmware
Browser - Gooogle Chrome
OS - MacOS Catalina 10.15.5

I've heard from someone else with a newer creality printer (ender 3 v2) that they....

the fix seems to be setting the baud rate to 115200 manually, and restarting the printer without the connection cable from the RPi...

So, I set the baud rate to 11520, then unplug the cable from the printer, then restart the printer? i'll try anything at this point, but I"m not sure if I have the sequence of events right.

@AlbertMN would have to speak on that, he's the one that posted about it over here

I'm curious if unchecking this box would make any difference for you @zsign817?

I’ll try both of the things listed here. Thanks for your tips. I will report back if it was successful.

I tried both tips. Unsuccessful. Still says to read line 2916. octoprint (1).log (50.1 KB)

What about setting the port as well instead of using auto and saving that setting? If it still doesn't work then you may want to consider enabling serial logging, restart octoprint, and try again. Once you have been unsuccessful, go to the issues on the OctoPrint Github Repo and post a new issue with all the requested information/logs,etc.because it's definitely establishing a connection, it just seems to be killing it right after.

@jneilliii Thank you for all of your input. I do appreciate you trying to help me. I'll do what you suggest and post a new issue on the Octoprint Github. I'm clearly out of my depth as I just don't know what else to do. Perhaps I'd be better off either reimaging the SD card again or even getting a newer Pi to try with. Again, Thank you for your help.

So there are guys on discord that seem to think this is a common problem with stock firmware where the usb/sd port is detected as serial port or something along those lines. They recommended new firmware but you've already switched to th3d so not sure if it's relevant. There are lots of th3d ender 3 users on the discord server, so you might want to pop into the support-printer channel and check there too.

Hey, so TH3D recently updated their firmware. I took the EZABL option off and reconnected my mechanical z-stop. Put the new firmware on my printer and now I can connect to the printer with no problem! Strange... Not going to complain though. I was getting frustrated with the EZABL and felt like I had more control with manual leveling. Maybe the EZABL was part of the problem, but maybe not.

2 Likes

Hello All
Since 3 weeks I'm having a Ender 3 Pro.
Just installed now Octoprint with a Web Cam and a Pi4B 8GB.
All went fine but the printer did not start the connection at all.
I read somewhere that the serial speed should be reduced to 115200 instead of 250000.
After I changed it to 115200 in the setup the printer was immediately available.

Remark: The Fix for 2x temperature also needs to be implemented for this new Endor 3 pro
to see the correct values, because the firmware still returns it in wrong format, see below.
Recv: ok
Send: M155 S2
Recv: ok
Recv: TT::13.8013.80 //0.000.00 BB::13.3313.33 //0.000.00 @@::00 BB@@::00

Hope that helps

Hello @XBoxOldie!

The latter one is a known issue. You may install this plugin:

Hello Ewald

I already did the fix in Octoprint and from that moment I was able to see the correct temperatures in Octoprint.

In the terminal of Octoprint the values are still double, received from the printers firmware.

Is there a change to force the printer vendor for a firmware update or is this already initiated for this known bug?
Is there a procedure available to flash the ender 3 firmware in case a new firmware will be available and can be downloaded to users for this brand new printer Ender3Pro?

However many thanks for your provided feedback.

The terminal is the bare output of the printer communication. The temperature issue is fixed after that to have a proper display in the graph etc.

Creality seems to be a bit stubborn concerning their firmware.

There are some videos on youtube that deal with updating Ender 3 firmware. Bus as you said, it's quite new. You may have to search google.

1 Like