Temperature reporting now working with new ender 3 V2

Yeah - this is a Creality bug.... They'll have to fix it - or you can use a 3rd party firmware to fix the problem.

I offer daily firmware builds on a subscription basis for those who don't want to learn to do it all themselves. https://marlin.crc.id.au/

It has sets for both BLTouch enabled and stock configurations.

Thanks for this fix, worked great after I copied the file then rebooted!!

I'd like to report that this fix also works for the Ender 3 Pro that is currently shipping with a 32-bit Creality 4.2.2 board.


Thanks for the fix, I can also report it fixed my temperature issues on my Ender 3 V2. Good job.

I just wanted to chime in and maybe this can be merged with another post about the Creality CR-6 SE which is suffering from the same problem and this fixed it. I just got my CR-6 today and I have had a ton of problems getting Simplfy3d to work right, especially my starting and ending scripts.

For anyone else experiencing this; the plugin mentioned above is the solution, and it works great.

With permission from @b-morgan who made the plugin fix, I have released a version on GitHub, meaning it can be installed via. url, or downloaded directly from GitHub; https://github.com/SimplyPrint/OctoPrint-Ender3V2TempFix

Will soon attempt to release it as an official plugin, visible in the plugin manager.

On a completely different note; while testing on two Ender-3 v2's, we experienced connection issues on both. The fix here is quite simple; disconnect the micro-USB cable going from Raspberry Pi to printer, turn off the printer and keep it shut down for at least 10 seconds, turn on the printer, wait a few seconds until it's properly booted, connect the cable again and it should work. The printer wasn't a big fan of the auto-detect for the baudrate, but setting it to 115200 manually did the trick.

Shouldn't this go into mainline? Or does it have to be a plug in? Good job making it easier for others anyways.

Reason it is not in core OctoPrint is it is Creality not adhering to standards as far as I know. Plugins mean it can be maintained outside of OctoPrint's release cycle, so say for example Creality updated their firmware to make it different again tomorrow, and shipped it, a plugin could be created, rather than users needing to wait for the next update.

Also, fixes for every kind of printer out there are a very bad thing to go into core, when Gina (OctoPrint creator) doesn't have access to every kind of firmware etc. etc. to work on updating OctoPrint - it would be very inefficient.

Plugin is live in the official plugin repo now.

1 Like

Am I right in assuming that all of takes to detect this kind of brokenness is doubled TT and BZb in what otherwise looks to be a temperature responses?

If so I could throw a detection for that into https://github.com/OctoPrint/OctoPrint-FirmwareCheck which I put on its own release cycle precisely for situations like this.

Yep. The temperature report looks like this; TT::27.9327.93 //0.000.00 BB::39.6739.67 //0.000.00 @@::00 BB@@::00

But as far as I know, it's not every single Ender-3 v2 that has it. It's like the "Creality Temperature Fix" issue for CR-10S Pro and CR-X, just different wrong formatting... The firmware reported by a printer having the issue is; Marlin Ver 1.0.1, protocol; 1.0 (gotten directly through OctoPrint). Creality likes messing up their temperature reports :smiley:

I built and flashed Marlin for my Ender 5 Pro. Am I right in thinking this issue will not affect me?

Depends where you got this Marlin from.
When it's from the Marlin website most likely not.
When from the Creality website there are some chances the error may consist.

1 Like

The CR-6 se is like this as well. but not marlin 2.0 can this help with the CR-6 issue? i notice that mine will show randomly like when it thinks it can see it, but it will stop showing it an then i have to check the terminal to see my temps and to make sure everything turned off when i am away. below is a M115 dump and the last line is the Temp line.

Send: M115
Recv: FIRMWARE_NAME:Marlin Creality 3D SOURCE_CODE_URL:https://github.com/MarlinFirmware/Marlin PROTOCOL_VERSION:1.0 MACHINE_TYPE:CR-6 SE EXTRUDER_COUNT:1 UUID:cede2a2f-41a2-4748-9b12-c55c62f367ff
Recv: Cap:EEPROM:1
Recv: Cap:PROGRESS:0
Recv: Cap:PRINT_JOB:1
Recv: Cap:Z_PROBE:1
Recv: ok
Send: M155 S2
Recv: ok
Recv: TT::25.4525.45 //0.000.00 BB::27.7327.73 //0.000.00 @@::00 BB@@::00

I got it, i used your zip file and put in in octopi and it is working at least so far, need further testing but it looks like it is working

So the plugin fixes the issue for CR-6 too? Can you try using the official plugin instead, and tell me if it works? You can install it directly from OctoPrint, within the "Plugin manager"

@AlbertMN I also shot that plugin a PR since I need a minor change before I can roll out auto detection in the firmware check plugin:

I actually thought I'd already done that on Tuesday, but I managed to actually create the PR against my own fork... :woman_facepalming: Somehow Github changed something in the workflow and it's way less straightforward now than it used to be.

1 Like

Awesome - merged.

Question is whether the plugin should be renamed "Creality Double Temperature Reporting Fix" (or something shorter, title work in progress :P) rather than its current name, if this issue also happens on CR-6 SE as @Justin_Clevenger says.

Is changing the name of a plugin an issue, @foosel ?

The name not, the identifier however is a bit of a headache that I'd like to avoid :sweat_smile: Nothing against having a name that differs from the identifier however in such cases.

My own fix something plugins are usually called "Fix-...", so maybe "Fix-Creality-Double-Temp"

Yeah, figured changing the identifier would be an issue... The identifier staying the same shouldn't be an issue though, it's just a matter of the appearance of the plugin. A name change might be best, to avoid confusion.

1 Like