Can't connect to Octopi.local at all

I have Octopi set up on my Raspberry pi and it's all connected to my printer. It worked perfectly fine earlier and I managed to log in to octopi.local, but now it just sits there loading for hours. I've been here for almost 2 hours now waiting for this stupid thing to connect. I've rebooted the pi and my computer multiple times, and it comes up saying Octoprint is starting, waiting for it to get ready, but then comes up with an error message. And then when I reload the page, it just sits and loads for hours and hours. I'm sick of it, all I want to do is print something and I've wasted 2 hours of my time.

Hi :slight_smile:

We need some more information.

  • Which raspberry and octopi are you using?
  • Is your raspberry on wifi or lan?
  • Is your pis power supply sufficient?
  • Which printer is it?

I would try to power down the pi, disconnect any usb device and start it again.
Sometimes printers draw so much power from the usb port that the pi doesn't work correctly.

Also, because you didn't setup anything so far, you could reflash octopi and try it again.

Well that happens more than once when you're 3D printing :wink:

It's a raspberry pi 3B and it's running on WiFi, I have it connected to a wall socket and my printer is a Creality Ender 3

:shushing_face: logs could also help

I physically cannot access the logs because octopi won't let me log in

Can you check on your router/access point if the pi is connected?
If yes try to connect to its ip instead of octopi.local.

It is connected, I can see it on my SkyHub. I've tried connecting to the ip through the browser instead but it still just sits and loads forever

Is the signal strengh ok?
Have tried an other browser or device?

And take care that your browser does not autocorrect to www.octopi.local.
octopi.local is just fine.

If you can see that then you can access it, otherwise you wouldn't be able to even get to this page. Logs aren't only available via the web interface, they can also be retrieved via SSH and the link behind the word "logs" tells you where they are.