Can't connect to octoprint.local

What is the problem?
So I wanted to setup Octoprint for my printer with a Raspberry Pi 3. When i connect it directly to my router it was perfectly working. But i have a long ethernet cable into my cellar, where my printer is. when I plug it in there I can't access the octopi.local website anymore. The green status LED on the ethernet port is on.

What did you already try to solve it?
I tried to connect a Laptop to the long ethernet cable. That worked perfectly.
I tried to reinstall octopi several times.
I was pinging it with the console in windows (didn't work)

Additional information about your network
I have a Raspberry Pi 3 Model B

So if I understand correctly - a short cable works, but a long cable doesn't? Or by 'direct' do you mean wired wireless?

Edit: Also make sure you are using http://octopi.local, not OctoPrint, since the title says one thing and the post says another

Exactly. Short cable works, the long one is not working. Yes I used http://octopi.local :slight_smile:

:thinking: Maybe the long cable gets some interference or noise etc, that your laptop can cope with, but the Pi can't really? Not sure of the specifics of the interface on the Pi, but I do know you can get shielded cables, that might help with the distance. What sort of distance are we looking at?

That could be possible. But at least on my laptop I get the same internet speed with the long and the short cable. I think the cable is about 30 meters long, but that should not really be a problem.
Now I heard that the official raspberry pi camera can cause some problems when plugged in incorrectly. I will reinstall octopi tomorrow and try it without the camera plugged in.
The cable I use is a pretty good one, but idk if it is a shielded cable

Just some thoughts, my long distance cabling is done through powerline, so I'm not really sure of the general solutions beyond that.

Thanks for your help. I will try the reinstall tomorrow. Then I'll let you know it it worked!

1 Like

I reinstalled everything yesterday. It has turned out that I can only access octoprint directly over the IP-Address and not with octopi.local

Have you changed the name of the RasPi in the raspi-config?