Can't connect to Octoprint on local network

I installed octoprint on a fresh install of lubuntu . I can connect on the octoprint box with localhost:5000 but not on pc connected to the same router using the ip address:5000 .

I checked to make sure no firewall is running on lubuntu by ruining ufw status and it isn't .
I tried using commands to open up iptables and got the same result .

im running the latest version of octoprint , trying to connect trough a windows 10 based pc using chrome / edge

What would cause this? What should i do to fix it ?

From the Windows PC, try commands in a terminal like ping ipaddress to verify that you can actually reach it. Perhaps the network settings are wrong somewhere.

I can ping both to and from the octoprint box with no issue .

If you have network connectivity (it sounds as though you do) and the Lubuntu server itself can access the local website and the Windows PC can't, then you might try from the Windows PC something akin to:

curl -v http://ipaddress:5000/

You might need to install curl for this to happen. If even that fails at least the -v part might give you a clue as to why it's failing. It could be the local firewall on Windows.

what i got back was

C:\Users\Kaze>curl -v

  • Trying
  • Connected to ( port 5000 (#0)

GET / HTTP/1.1
User-Agent: curl/7.55.1
Accept: /

  • Recv failure: Connection was reset
  • Closing connection 0
    curl: (56) Recv failure: Connection was reset

It sounds like maybe Lubuntu might have a firewall that's preventing port 5000, but that's a guess.