Can't connect to octoprint on my computer or phone's web browser

What is the problem?
Hello,
I am having trouble connecting to octoprint via wifi on a web browser. I am running the latest version of octopi on a raspberry pi 4 B. I can connect just fine to the octoprint server via ethernet on the pi but the wifi doesn't work. However, on apps such as plabric for android, I have successfully connected to octoprint and printed parts with it but that was after I connected over ethernet to my computer to install the plugin for plabric.

When I try to connect over wifi on my computer with chrome it says "octopi.local’s server IP address could not be found."

I also checked my router to make sure that the pi was actually connected to the router and it was.
What did you already try to solve it?
I tried:
-putting my wifi settings in to wpa_supplicant
-re-flashing the image
-moving the pi closer to the router
-using a pi 3 B
-using a different sd card
-disabling all my plugins
-checking router settings
Logs (syslog, dmesg, ... no logs, no support)

Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)

If you have your RPi connected to your network via both WiFi and Ethernet, then your network is probably confused because there are two paths (and two IPs) associated with the same name.

Normally, there is a router (or modem/router) that contains the WiFi access point. This router will handle routing traffic from your WiFi connected devices and your Ethernet connected devices. The RPi just needs one (either WiFi or Ethernet) and everyone should be able to talk to it.

After you fix the RPi to have only one connection, you may need to reboot the router and everything else in the network to get them all to forget the connection you removed from the RPi.

This is the best I can do without details about your network. If you need more help, please provide more detail.

Is there any specific way to go about fixing that problem or should I just take out the ethernet cable and restart the router?

I'm not sure if this is quite correct.
I have 3 Pis with Octopi/OctoPrint running on them connectet via LAN to the router and all are named octopi. And there is an additional WiFi connection named octopi with a own IP address.
They all can be well distinguished with their MAC addresses.

@Gandagorn
If you have the chance to connect a HDMI monitor TV to the pi, at the end of the boot sequence you will get the IP address the PI got from the router.

@Ewald_Ikemann
what should I do then?

When you get the IP address, you can reach the web interface by typing this address into the address line of your browser. Like

http://192.168.1.10

Or whatever the actual address is.

when i tried that it said that the ip address didnt send any data

If you don't use names in your network, then all the systems can have the same name. This is not a recommended way to configure a local network.

The ARP protocol is designed to optimize LAN-LAN communications using MAC addresses.

@Gandagorn My recommendation is that each system in your Local Area Network (LAN) except your router have only one network connection, and each system in your LAN have a unique name. The router is probably configured to be a DHCP server and a DNS server. The router should have a web GUI so you can monitor DHCP and DNS.

Reboot the router, the RPi, and your desktop. Verify that those three systems are happy talking to each other and you can view the OctoPrint web server, the router web server, and you can use PuTTY / SSH to connect to the RPi.

With your LAN configured this way. Let us know (with as much detail as possible) what works and what doesn't work and we'll go from there.

How can you tell which one you are connecting to then if they all have the same name?. I have numerous Pi's and they all have different names. DNS will get awfully confused because it tries to align NAMES to IP's, not NAMES to MAC addresses. The relationship between IP and MAC operates at the bottom of the stack - when a device throws an ARP to do IP address detection it doesn't care about the name. But most routers DO. It depends how clever the DHCP server is and whether its connected to the DNS server.

I've been building and managing networks using TCP/IP for over 30 years, trust me, having machines with the same name is asking for trouble. It really isn't hard to change:
ssh onto the pi, using its IP address; and the default password - unless you've changed it WHICH OF COURSE YOU MUST.
then type sudo vi /etc/hostname, press the letter d, then the letter w;
that removes the name, then press i - for insert
type your new name
then press the ESC key and then colon w q

@b-morgan
so you mean to assign each system a static ip?

No.

The router (which is the DHCP server, the DNS server, the WiFi access point, and the gateway to the internet) is the only static IP needed. Every other system in your LAN will be assigned a dynamic IP from the DHCP pool and each system's hostname will be entered into the DNS server and point to the assigned dynamic IP.

These dynamic IP address assignments will most likely never change. If you want to assign static IP addresses, you can, but it is not necessary. For example, my DHCP pool is x.x.x.100-.x.x.x.254 (netmask 255.255.255.0), the router is x.x.x.1 and I only have a couple of IP addresses assigned in the x.x.x.2-x.x.x99 range. The router is capable of hosting a VPN should I ever need outside access. All of the LAN systems use the router as their DNS server and all of my LAN-LAN connections are by name.

Obviously you are right :+1: (checked myself just now).
I missed that point because I always connect via IP address.

For different hostnames for lan and wifi, I found this:

https://www.raspberrypi.org/forums/viewtopic.php?t=72699

If you get this error:

RTNETLINK answers: File exists

try this:

1 Like

So, I re-flashed the image and now I can't even ssh into the pi. When I ran an ip scanner, it says all the hosts are down. is that a problem with the raspberry pi or something else?

When you reflash the image, the file in the boot partition called ssh disappears, so pull the card, and create a file in the boot partition called ssh... That will then re-enable ssh. When the file isn't there raspbian doesn't start the ssh daemon. And if you boot with the network cable disconnected it will give itself a self assigned address starting 169.254.x.y. This will show up on the printer display - it does on my Ender 3's

AFAIK, with OctoPi SSH is enabled by default.