Can't connect to octoprint through chrome and can't ping it RBP

What is the problem?
I'm new to octoprint
I can't connect to octoprint through chrome on wifi and can't ping the RBP either.
but the funny thing is that it works fine on my iPhone x

it just says

Your Internet access is blocked

Firewall or antivirus software may have blocked the connection.



i have tried looking at my firewall in chrome, windows and Avast but nothing makes sens pls help

What did you already try to solve it?
reflashing my sd card
connecting with a cable through a switch solved the problem but is not reliable

Logs (syslog, dmesg, ... no logs, no support)


Pinging with 32 bytes of data:
General failure.
General failure.
General failure.
General failure.

Ping statistics for
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)

running avast antivirus
using chrome
can't ping RBP
Using WiFi
Raspberry pi 4b

Re-read the OctoPrint/OctoPi setup document. You make 2 changes while on your desktop machine. WIFI - SSID, and then the static IP address. Adding the "ssh" empty file.

Everything else is done in "rasp-config" , you might consider doing this w/ a kb/mouse/monitor.

Then follow the http-gui setup instructions. Read a bit more, all the answers are in the documentation.

I'm a RTFM - (read the FINE manual) Systems & Network Engineer, I've got 27+ years of doing this stuff. Back in 1995, I was ripping into the "Windows Registry" to fix things. I could easily identify controller & control panel conflicts in Mac OS 7,8,9. :slight_smile: Patience Grasshopper!

Sounds a lot like the antivirus is causing the problem - if it works from your phone, then it is connected to the Wifi and running. @joel_huebner I think you may have overlooked that detail.

Another Windows evil, I forgot.

I lived in a Windoz world for 27+ years. 1/2 my life watching progress bars, or the lovely BSOD!

I have one new HP W10 Laptop, ChromeBook, HP Netbook - 32bit Atom processor running Pi-86 OS. Pixel 4, Tab-4c, 6-10 rpi's in various configurations. No pico yet. LOL I've been Windows Free for ~3 years. Now I have one W10 laptop, and a license for 1 VM for the past 3 months or so.

octoprint is online and I can reach it from my phone. therefore I think it's my computer and something on it that is causing problems. I have uninstalled Avast. tried disabled windows defender but nothing helps.

i have uninstalled avast and tried disabling windows defender but none of that helped

Found the Problem. it was NordVPN that was causing my problems it's now uninstalled and it's running fine from my computer.

1 Like

I'm using a mobile hotspot, not a router, and my fix was to switch it from 5Ghz to 2.4Ghz. Then the OctoPi could connect easily.