Cant connect to Octoprint via OpenVPN

What is the problem? Cant connect to octoprint remotely when accessing via OpenVPN connection

What did you already try to solve it? Screen comes up saying 'Connecting to Octoprint server' but it never loads so im a bit stuck! Tried to connect with android phone and laptop remotely configured as clients.

Logs (syslog, dmesg, ... no logs, no support) No logs available as im assuming its a setting ive missed somewhere!

EDIT: Just found this in the logs when i tried to connect again:

2020-07-02 19:34:10,656 - octoprint.server.util.flask - INFO - Passively logging in user dansharpy from ::ffff:
2020-07-02 19:34:10,657 - octoprint.access.users - INFO - Logged in user: dansharpy
2020-07-02 19:34:12,187 - octoprint.server.util.sockjs - INFO - New connection from client: ::ffff:

Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...) TP Link Archer VR900 router with Open VPN configured. Octoprint on raspberry pi4 2gb. Static IP for router and Octoprint. Can access via octopi.local and ip when within network no problem. Can also access pi over ssh when on VPN connection. Help!

Also id just like to say thank you to everyone involved with Octoprint. Ive only had my printer for about a month and had Octoprint hooked up since day 1 and im loving it!

Hi Dan, I use L2TP-IPSEC for my VPN and works fine when I connect to my Octo Print server..... what broweser are you using when you try and log on to Octo via your VPN?
I use firefox my self.

Hi delta, I've tried Vivaldi, chrome and Firefox and still no joy. Would the UDP/TCP setting on the router make any difference? Sorry I'm a bit new to VPN stuff! I also can't access my home assistant server over the VPN so I'm thinking it's maybe more or a general setup issue than something specific to octoprint. Thanks

VPN will use UDP but as you already connect to your vpn and it works then thats not the problem..........Do you know what ip address is assigned to your devoce when you connect via VPN ?

Do you host your own VPN server?

The archer vr900 router I have had open on set up on it so it acts as the VPN server directly. However what has occured to me is that all the internal IP addresses are withing the range to (static IP's are between 100-120) but the VPN subnet/netmask is do I need to forward that subnet so it can see devices from the internal IP address pool? Or forward the VPN service port? Sorry if these are noob questions!