Can't connect to printer, warning corrupt line

What is the problem?
I get a message of: received line:
Followed by: WARNING - The received line contains at least one null byte character at position 19, this hints at some data corruption going on
The position of the character changes if I try again

What did you already try to solve it?
Removed SD card
Tried to use a different computer
Reinstalled octoprint
Wait for start on connect
Auto serial port and baudrate

Additional information about your setup
I am using a CR10-Max and octoprint on a windows machine

Creality printers are well known for being both very susceptible to EMI and a generator of EMI (the worst possible combination). This most often manifests itself in communication errors such as you are seeing.

The first remedy to try is to use a short, high quality, shielded USB cable with ferrite beads (at both ends is best). Something like this.

You may find that the routing of the USB cable (or the position of the devices at each end) may have an effect on the reliability of the communications.

If you search this forum for Creality communication issues you will find numerous topics some with solutions that worked for that case.