Can't connect to second OctoPrint on same RasPi?

So I'm trying to set up two instances Octoprint for my teacher and so far I've got the first instance up and working, but the second one I can't seem to connect to. The service SEEMS to be working, but when I try to connect to it, it refuses to connect.

Its running on a RasPi 3+ (I think), and its wire connected to its own router that the computer is connect to via WiFi. The computer I'm using to connect to OctoPrint is a iMac. If anyone can give me some suggestions to run tomorrow when I go back that would be very helpful.

Hi :slight_smile:
Well I think it would be the easiest if you tell us what you have done so far and how you configured the second octoprint instance.

Edit: also I found this guide quite helpful. Maybe it helps you too.

This is the guide that I used. I basically tried to follow this guide and I thought I did everything correctly. I do have it connected to two different routers so now I'm thinking I might have to change some settings one both of them.

GNU nano 2.7.4 File: 99-usb.rules

SUBSYSTEM=="tty", ATTRS{idVendor}==“0403”, ATTRS{idProduct}==“6001”, ATTRS{devpath}=="1.3", SYMLINK+="ttyEND”
SUBSYSTEM=="tty", ATTRS{idVendor}==“0424”, ATTRS{idProduct}=="75232514”, ATTRS{devpath}=="1", SYMLINK+="ttyWIS”

  GNU nano 2.7.4                                            File: /etc/init.d/octoprint2                                                       

#!/bin/sh

### BEGIN INIT INFO
# Provides:          octoprint2
# Required-Start:    $local_fs networking
# Required-Stop:
# Should-Start:
# Should-Stop:
# Default-Start:     2 3 4 5
# Default-Stop:      0 1 6
# Short-Description: octoprint2 daemon
# Description:       Starts the octoprint2 daemon with the user specified in
#                    /etc/default/octoprint2.
### END INIT INFO

# Author: Sami Olmari

PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
DESC="octoprint2 Daemon"
NAME="octoprint2"
DAEMON=/usr/bin/octoprint
PIDFILE=/var/run/$NAME.pid
PKGNAME=octoprint2
SCRIPTNAME=/etc/init.d/$PKGNAME

pi@octopi : /etc/udev/rules.d $ systemctl status octoprint2.service

octoprint2.service - LSB: octoprint daemon

Loaded: loaded (/etc/init.d/octoprint2; generated; vendor preset: enabled)

Active: active (running) since Thu 2018-11-15 12:43:09 GMT; 47min ago

Docs: man:systemd-sysv-generator(8)

CGroup: /system.slice/octoprint2.service

└─401 /home/pi/oprint/bin/python2 /home/pi/oprint/bin/octoprint serve --host=127.0.0.1 --port=5001 --basedir /home/pi/.octoprint2

Nov 15 12:43:09 octopi systemd[1]: Starting LSB: octoprint2 daemon...

Nov 15 12:43:09 octopi octoprint2[308]: Starting octoprint2 Daemon: octoprint2.

Nov 15 12:43:09 octopi systemd[1]: Started LSB: octoprint2 daemon.

GNU nano 2.7.4                                           File: /etc/haproxy/haproxy.cfg                                                      

global
        maxconn 4096
        user haproxy
        group haproxy
        log 127.0.0.1 local1 debug

defaults
        log     global
        mode    http
        option  httplog
        option  dontlognull
        retries 3
        option redispatch
        option http-server-close
        option forwardfor
        maxconn 2000
        timeout connect 5s
        timeout client  15min
        timeout server  15min

frontend public
        bind :::80 v4v6
        bind :::443 v4v6 ssl crt /etc/ssl/snakeoil.pem
        option forwardfor except 127.0.0.1
        use_backend webcam if { path_beg /webcam/ }
        default_backend octoprint

backend end
        reqrep ^([^\ :]*)\ /end/(.*) \1\ /\2
        option forwardfor
        server octoprint1 127.0.0.1:5000
        acl needs_scheme req.hdr_cnt(X-Scheme) eq 0
        reqadd X-Scheme:\ https if needs_scheme { ssl_fc }
        reqadd X-Scheme:\ http if needs_scheme !{ ssl_fc }
        reqadd X-Script-Name:\ /end

backend wis
        reqrep ^([^\ :]*)\ /wis/(.*) \1\ /\2
        option forwardfor
        server octoprint1 127.0.0.1:5001
        acl needs_scheme req.hdr_cnt(X-Scheme) eq 0
        reqadd X-Scheme:\ https if needs_scheme { ssl_fc }
        reqadd X-Scheme:\ http if needs_scheme !{ ssl_fc }
        reqadd X-Script-Name:\ /wis

backend octoprint
        acl needs_scheme req.hdr_cnt(X-Scheme) eq 0

        reqrep ^([^\ :]*)\ /(.*) \1\ /\2
        reqadd X-Scheme:\ https if needs_scheme { ssl_fc }
        reqadd X-Scheme:\ http if needs_scheme !{ ssl_fc }
        option forwardfor
        server octoprint1 127.0.0.1:5000
        errorfile 503 /etc/haproxy/errors/503-no-octoprint.http

backend webcam
        reqrep ^([^\ :]*)\ /webcam/(.*)     \1\ /\2
        server webcam1  127.0.0.1:8080
        errorfile 503 /etc/haproxy/errors/503-no-webcam.http

This is what I got. If I try to go through this port (192.168.x.x:5001 or 5000) it refuses to connect.