Can't connect via FTP

Can't connect via FTP

I tried via Forklift (macOS) to connect to my Octopi, but didn't get it!


FTP (passive and not passive), FTP TLS (passive and not passive), SFTP with name and PW

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle (318.7 KB)

latest versions of Octoprint and all my plugins

thanks in advance for your help!

Did you get a specific error message?

yes! >> "Sandro@octopi.local: Permission denied (publickey,password)."
I also tried with an newly generated API-key and with an IP-adress like 192.168...

OctoPrint's login info is not the same as the OS login. The API key in OctoPrint won't let you in to the system.

On an OctoPi install, the username is pi and the password is raspberry unless you previously logged in and changed it, it's not the same password as you use to login to the web UI.

yes, I had read that, but even with name=pi and pw=raspberry there is no chance...
same error message ...!
Bildschirmfoto 2021-11-20 um 22.33.19

Have you tried using the IP of the Pi?
And can you SSH into it?

Is there an FTP service running on octopi?

I know there is none on mine:

nmap kiwi.intern
Starting Nmap 7.92 ( ) at 2021-11-21 00:40 CET
Nmap scan report for kiwi.intern (
Host is up (0.0013s latency).
Other addresses for kiwi.intern (not scanned): fded::cafe:18
Not shown: 995 closed tcp ports (reset)
22/tcp  open  ssh
80/tcp  open  http
139/tcp open  netbios-ssn
443/tcp open  https
445/tcp open  microsoft-ds
MAC Address: B8:27:EB:3F:66:A1 (Raspberry Pi Foundation)

Nmap done: 1 IP address (1 host up) scanned in 0.25 seconds

No port 20, 21. FTP is so 1990

(Ok, I read it up, an extended version of scp goes by the moniker SFTP. When you can ssh into a box scp works as well. You can always test it from the terminal on OSX and test if its a limitation of that other program)

Yes, you can reach it by e.g. WinSCP:

FTP != SCP which is a protocol run over SSH. OctoPi doesn't ship with FTP or SFTP, use SCP.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.