Can't connect without 5v power pin

What is the problem?

My ender 3 (manufactured March of this year) refuses to connect to octoprint if I tape off the 5v power pin.

I want to stop the screen from running (and fans) when the printer is off, but it's not possible with the pi supplying power to the printer.

What did you already try to solve it?

Tried 5 different USB cables, tried rebooting everything. The device doesn't show up via lsusb either without the 5v pin.

I've also tried several fresh installs of octoprint with no success.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)

Latest version of everything. Serial just shows unable to detect serial port, which is expected due to the printer not being listed via lsusb.

Assuming printer power of off, this is expected behavior. Printer's mainboard contains a chip responsible for USB communication. When printer power is off this chip gets power via USB cable's 5v wire. If you cut this power source as well, then RPI won't be able to communicate with the printer board and lsusb will show port as not connected.

As for switching screen and fans off, using OutsourcedGuru's USBControl plugin may be a better option than taping the pin. Check this topic for more details OctoPrint-USBControl

I, personally, ended up using "surgical" approach and cut +5v wire in my USB cable. This is good for regular operations, but for flashing firmware I use another (uncut) USB cable, since it is not recommended to have printer power on while updating firmware.

Thanks

1 Like

Hey. Thanks for responding.

I understand that I wouldn't be able to connect to the printer with the power off and the 5v taped.

The situation I described occurs with the printer power on and connected to the raspberry pi with the 5v pin taped.

Without the 5v pin taped, it connects as expected

I assume you did not accidentality taped the GND pin?

1 Like

Just noting that OctoPrint disconnects from my own printer when I toggle off the USB power (that 5V).

This from the OctoPrint-USBControl plugin README.md: