Can't copy files to symlinked location for backup

What is the problem?

I created a symlink under ~/.octoprint/uploads to a backup folder on my NAS:

lrwxrwxrwx  1 pi pi       50 Feb 24 18:44  backup -> '/mnt/public/Files/Utilities/3D Printing/Octoprint/'

When I try to move/rename files to that location from the Files widget in Octoprint, it fails with "unable to move file or folder":

In the tornado.log I see this:

2024-02-24 18:45:23 - tornado.access - WARNING - 409 POST /api/files/local/CrystalDragon_NewLegs_ShortTail_Curled4(1).gcode (::ffff:192.168.1.107) 53.01ms
2024-02-24 18:45:23 - tornado.access - INFO - 200 POST /api/files/local/CrystalDragon_NewLegs_ShortTail_Curled4(1).gcode (::ffff:192.168.1.107) 54.00ms

What did you already try to solve it?

Checked permissions on mount point, symlink, etc. to confirm 'pi' user has write access to symlink's target location. Normal Linux command-line commands to move files to/from the symlink work as expected. I also tried with a symlink to a folder without a space in the name but the same error occured.

Systeminfo Bundle

octoprint-systeminfo-20240224184853.zip (170.6 KB)

Nobody else, eh?