Can't find octopi-wpa-supplicant.txt on 0.15.1


#1

I wrote the image of 0.15.1 on my micro sd (samsung evo 32gb) and do not appear to have the octopi-wpa-supplicant.txt file on the file directory of the micro sd plugged into my computer. I might be missing something. I only have three .txt files: cmdline.txt, config.txt, and issue.txt.

The guide said to access the file on the root of your flashed card. Is that supposed to be a folder or is there a specific way to root the card to access the file?


#2

There are over 20 files (7 .txt) and a couple of directories in the /boot partition. What is the OS of the system you used to write the SD card and what program did you use?

Did you verify the image with a checksum after you downloaded it? On this page under the download button is the MD5sum for the .zip file. Search for an MD5 checksum utility for your OS.


#3

This gave me the idea to re-download through Edge instead of Chrome and it seems to have worked this time. Thanks for your help.


#4

I am having this problem as well. I've downloaded the .zip file of the latest image from both the OctoPrint site and through GitHub, and via multiple browsers, and I've confirmed the checksum for the .zip file is correct. I've also set my OS (Mac OS X Mojave) to show hidden files.

However, when I look in "Finder," although I can see the "boot" directory, the octopi-wpa-supplicant.txt file is missing. As Wilson05 said, I only see three .txt files - cmdline.txt, config.txt, and issue.txt.

I tried booting the Raspberry Pi using the image, without setting up WiFi, but it fails to boot. Googling this issue leads to lots of responses about confirming that the image file was the correct one, and that it downloaded appropriately -- I think I've confirmed that via multi-site downloads and checksum confirmation.

Any other ideas?

Thanks,
Matt


#5

Did you flash the octopi.zip file to the microSD using Etcher?
Was the file already octopi.img or similar, having downloaded it?

curl -L -o ~/Desktop/octopi.zip https://octopi.octoprint.org/latest

Flash the octopi.zip from your Desktop with Etcher to the microSD.
Remove/replace the microSD.

sudo ls -l /Volumes/boot/*.txt

#6

The file I downloaded was "octopi-stretch-lite-0.15.1.zip" . I extracted the .zip file, which produced an .img file of the same name, which I then wrote to the microSD using PiFiller.


#7

Problem solved. Bought a new MicroSD card (32GB) and it worked fine. Not sure why the other card didn't work; I pulled it out of a Pi that was already running OctoPi; I was just trying to update to the newest version with a clean install.


#8

Sunday, January 6 @ 1:30PM PST:

Using my instructions above and following it exactly on a MacBook (macOS Mojave 10.14.2), using curl (7.54.0 (x86_64-apple-darwin18.0) libcurl/7.54.0 LibreSSL/2.6.4 zlib/1.2.11 nghttp2/1.24.1) and Etcher (1.4.4) to a 16GB microSD card...

Output of curl command (3 minutes):

54%20PM

Output of "sudo ls -l /Volumes/boot/*.txt" after flash with Etcher (5 minutes)

12%20PM

Note that the file octopi-wpa-supplicant.txt has the expected content.

Can you describe what was different on your workstation? (Operating system with version, version of curl curl --version, version of Etcher?)

The big difference I see is that three of those text files adhere to the old 8.3 filename standard for short filenames. You would think that the final octoprint.txt file also conforms, unfortunately it's in the same name-mashing space as OCTOPR~n.TXT which is what Microsoft would issue to long filenames in order to store them. Is this a Windows-related problem in which it's trying to create short filenames?

If so, then try instead: sudo -l *.TXT (ALLCAPS on that extension). If you seen two or more files of this kind, then you can thank Microsoft for being painfully stupid.