Can't find the ip address on my computer

installing a rasberry pi zero w with octoprint so i can run it off my ender 3. i got it flashed onto the sd card and edited the file to put in my internet username and password then i put the sd into the rasberry pi and see the led green light come on, but i can not find the ip address on my network. Not sure if i did something wrong and it is not connecting!

You should really upgrade to at least a pi 3.
Using a zero can affect the print quality.

You need to enter your wifi credentials in there - not username and password for your isp.

1 Like

Assuming you are trying to ssh into the pi, that your WPA credentials are correct, and that the pi is booting and getting on your network......

  1. You can use nmap to find pcs on your network listening on port 22
$nmap -Ap 22
Nmap scan report for Ender (192.168.1.XXX)
Host is up (0.0065s latency).

22/tcp open  ssh     OpenSSH 7.9p1 Raspbian 10+deb10u2 (protocol 2.0)
| ssh-hostkey: 
2048 XX:XX:XX:XX:XX....

You also need to enable ssh on the pi via raspi-config or by placing a file called ssh on the boot drive.

I didn't know nmap for windows was a thing, but it is:

Where do I get this ssh
file from?

Are you in GB or the US? - You may have to set to comment one of the lines in the octopi-wpa-supplicant.txt

AFAIK, with the recent OctoPi images, SSH is activated. With a pure Raspbian you have to do this.

The file mentioned is just an empty file with the name SSH.
For using windows with SSH you can get Putty.

I'm in the u.s, so your saying is the ssh should already be activated? If so what else could be wrong?

Do you have the chance to connect an HDMI monitor or TV to the Pi?
At the end of the startup sequence you get the PI's IP-address.
With that you should be able to log into SSH.
Username normally is pi and the password is raspberry.
All in small letters and you get no respond on the screen when typing in the password.

‘raspberry’, not ‘raspbian’

Ooopss - you are correct...

Nothing is happening if I plug it in through HDMI, pretty close to giving up on this and just continuing to print through usb cable

No idea what I did wrong but I wiped my ad card clean and redid everything and now its working

1 Like

As suggested, you'll want to upgrade this with a Pi 3B or better to make good-quality prints. Connecting to it is just a first step. Creating beautiful parts is the destination.

You can enable ssh via raspi-config or by placing an empty file called ssh on the boot partition. Don't put anything in this file and don't give it an extension.

 $touch /boot/ssh

Adding the file while configuring the SD will enable ssh at first boot and prevent the need to ever connect the Pi to a monitor.

You may also be able to access the devices without knowing the ip using mDNS (Bonjour)

$ssh raspberrypi.local 

where raspberry pi is the hostname of the device.

Here's an article on a headless setup (I just skimmed it but it looks pretty much on point )

I'd be happy to write up step by step if there is really that much interest.

SSH works from Windows 10, Use PowerShell, not the the(x86).

How to Enable and Use Windows 10’s New Built-in SSH Commands

1 Like

In suggesting the ssh under PowerShell in Windows 10, you might also indicate what level of support it has for hostname lookup. For example, does it do a good job of resolving octopi.local into the expected IP address or does it fail at this? Does it work with just octopi (resolving with a NETBIOS broadcast over TCP)?