Can't get Elegoo Neptune 3 Pro to connect to Octoprint OctoPrint 1.8.7

What is the problem?

I am unable to connect my Elegoo Neptune 3 Pro to Octoprint. I am running Ubuntu in Windows 11 and have gone through the OctoPrint setup and that seems to be functioning properly but I can't get OctoPrint to see my printer.

My printer is showing up in Device Manager and I am able to send files via USB cable to Cura to print. Inputing the Port and Baud that I'm seeing in Device Manager don't help OctoPrint discover my printer. It will say "Opening Serial Connection".

I'm fairly new to Linux so perhaps there's a setting I missed.

Thank you for any help you can offer.

What did you already try to solve it?

  • Tried AUTO find for Baud and Port.
  • Found my port number and baud but Octoprint just says "opening serial connection" and nothing happens
  • Read help topics similar to my issue but couldn't find a solution.
  • Tried removing "brltty" but it isn't installed.
  • Checked to make sure the USB cord isn't just a power cord but has data as well. I can see the printer in Device Manager. Also I'm able to send files to print direct from laptop to Cura.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

octoprint.log (189.2 KB) (17.5 KB)

Additional information about your setup

Octoprint Version

Elegoo Neptune 3 Pro

Printer Firmware

Printer UI Version


System Manufacturer ASUSTeK COMPUTER INC.
System Model VivoBook_ASUS Laptop E210MA_L210MA
System Type x64-based PC
System SKU
Processor Intel(R) Celeron(R) N4020 CPU @ 1.10GHz, 1101 Mhz, 2 Core(s), 2 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. E210MA.306, 10/29/2020
SMBIOS Version 3.2
Embedded Controller Version 255.255
BaseBoard Manufacturer ASUSTeK COMPUTER INC.
BaseBoard Product E210MA
Installed Physical Memory (RAM) 4.00 GB

Chrome Version 113.0.5672.126 (Official Build) (64-bit)

Operating System:
Windows 11 running Ubuntu 22.04.2 LTS


Hi :tentacle:

I don't quite get this part

How are you running Ubuntu? In a VM? Via WSL?

Hello yes, via WSL using this as a guide:

The problem with wsl is that it doesn't allow usb passthrough (at least not that I'm aware of).
There are options to get usb into wsl, but I would highly recommend not doing it.

And aside from the usb issue a slow dualcore with 4gb ram running windows 11 + linux + an OctoPrint host at the same time doesn't sound like a good idea :slight_smile:

If I were you I would either install OctoPrint on windows (if you prefer windows), or completely switch to linux.

For windows you can try this installer and for linux this one.

Thank you!

Yeah it's a slow laptop :smile: He's chugging along with everything going on.

I didn't realize I could install via Windows until after I had already got Linux going so I'll give that a shot.


1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.