Can't get OctoPi Desktop to load on Rpi 4B

Did a fresh install of Octoprint (v0,18) and unable to get GUI desktop to load on Pi


What did you already try to solve it?

Reformatted SD card, downloaded octopi-buster-armhf-lite-0.180
flashed image to SD card with Balena Etcher . Set up octoprint on Pi 4B
able to connect to WiFi and connects to remote PC - Desktop appears on PC
at the RPi end only text appears -

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)


Additional information about your setup

OctoPrint version=1.5.2, OctoPi version= 0.18.0, printer=Anycubic I3 Mega S, firmware =Marlin, browser, operating system, ... as much data as possible

Terminal indicates the image comes w/o desktop environment installed
tried t install via
sudo /home/pi/scripts/install-desktop

download was sucessful - entered sudo-reboot at prompt
system beboots but no GUI desktop appears

entered sudo raspi-config
went to page /option that allows you to boot with GUI/desktop with auto login (S5)
terminal responds with= there was an error running option S5 boot / auto login

entered sudo apt-get install lightdm' to allow configuration of boot to desktop
system becomes unresponsive on get > at terminal line - - - have to shut off to get Pi responsive

Next steps??

would help a lot if we knew which error :slight_smile:


sudo apt update && sudo apt -y install xserver-xorg && sudo apt -y install raspberrypi-ui-mods && sudo apt -y install lightdm

Thanks - - I listed all of the error message I could see. Is there a better way to see what the error was from??

Also - should I try the commands you listed above as individual commands or as a string as written?

Well I thought it might be easier for you if I put them in one string but of course you can run them as individual commands and check if you get errors.

Thanks - still can't get the octopring desktop to load on my RPi 4B. I can get the web interface to run on my Windows desktop but only terminal script on the local pi - here are the specifics:

browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/89.0.4389.128 Safari/537.36
connectivity.connection_ok: true
connectivity.enabled: false true
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1500
env.hardware.ram: 3959984128
env.os.bits: 32 linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 4 Model B Rev 1.1
env.plugins.pi_support.octopi_version: 0.18.0
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 20.3.3
env.python.version: 3.7.3
env.python.virtualenv: true
octoprint.safe_mode: false
octoprint.version: 1.5.3
printer.firmware: Marlin 1.1.9 (Github, davidramiro) MARLIN-

Although the update seem to go smoothly - when I reboot the Pi can't get it to run in the GUI mode - only terminal script. I have redownloaded octoprint and flashed several times.
It used to work fine,,,,but I had some issues that required me to re-install the sofware.
Any help appreciated!

OK - making some progress - after reflashin again and using the sudo commands listed above - I now get the default Debian log in GUI = = but it will not accept my Octopi user name and login.
Note - when interfacing Octoprint via Wifi from my PC desktop - the username and password work fine. I aslo tried the default pi and raspberry combo - no luck. I am aware that these are case sensitive.
Next steps??

I changed the topic title from "...OctoPrint Desktop..." to "...OctoPi Desktop..." to more accurately reflect the contents.

It should be pi / raspberry

Which keyboard layout do you use? Some keys might be in another position on your keyboard.
For example when using a german keyboard layout you have to press the Z key for Y and vise versa.
You can change the keyboard layout with sudo raspi-config in the console or in ssh.
In ssh pi / raspberry should work without issues.