Can't get Octopi to boot/startup

Hi everyone,

I would love some help from the community as I am having some difficulty getting Octopi installed on my Raspberry Pi 3 B+.

I have downloaded the Octopi image and used Etcher to flash it to my SD card and modified the file to add my Wi-Fi network credentials as the instructions indicated. However when I install the SD into the Raspberry Pi and plug it in, nothing seems to happen. I connected amouse, keyboard and monitor to the Raspberry Pi and this is what appears on the screen.

It does not go through the install process as would seem to be what should happen next. I have tried several different SD cards thinking it might be the issue but I get the same result.

Separately I have been able to use the same procedures to install the Raspbian OS with no problems. I flashed the image and it boots right up to the install screen where I was able to select my Wi-Fi network and then go all the way through the install process to get the Raspbian desktop OS running.

So I know it is capable of working, I just don't know why Octopi won't install.


A kernel panic like that means that it can't mount the second (ext4) partition. This is often associated with a botched install.

Start over


What do you mean by a botched installed? I followed the instructions exactly using the image file from the OctoPrint website and Etcher to flash the disk. The start over link you provided used some additional tools that I'm not familiar with. Is there a way to fix the second partition so it can be read?

Lastly since I'm able to install the standard raspberry OS raspbian is there a way to just run Octoprint on the raspbian OS instead of using Octopi?

I wrote the content there in the link provided. I wanted to provide a set of (seemingly) foolproof steps to apply (flash) an IMG to the Pi.

Over the past couple of years I've noticed that many Windows-based users end up where you are now, a kernel panic. There's a step there in which your operating system is trying to "help" you (I'm guessing) by trying to auto-unzip the file from the website. And then, even your browser may be trying to "add some value" by messing things up.

In a nutshell this (admittedly weird) set of instructions tries to prevent either Windows's Explorer or the browser from adjusting the IMG file itself in such a way that Etcher flashes a bad pair of partitions. (There are times when even macOS screws up too, for what it's worth.)

Thanks OutsourcedGuru,

I was able to resolve the problem. the key was in the note not to format the second partition. I kept accepting the format request after the flash was complete. I ignored it after your last note and I was able to get it to finally boot up.