Can't get Plugin to Install

What is the problem?

I cannot get the Ender3v2tempfix plugin to install on my Raspberry Pi 4.

What did you already try to solve it?

I have tried to install it both in the command line and via URL, but with no success. I keep getting a "Command "python egg_info" failed with error code 255 in /tmp/pip-req-build-0kpq5P" error.

Have you tried running in safe mode and if so did it solve the issue?


Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

I don't think this is a loggable issue by OctoPrint

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Latest OctoPi version, Ender 5 Pro, Rasbian

Thanks for your help!

Hello @Redwood74

You mean this one?

So please do it.

Are you so sure? There is also a plugin_pluginmanager_console.log

1.4.2 or 1.5.0rc3?

1 Like

Or alternatively, 0.17 or 0.18rc... this is why people have to be specific...

1 Like

I was able to get it to install through the printer interface instead of the command line. Thanks!

OctoPrint plugins usually are meant to be installed via the plugin manager of OctoPrint. :face_with_raised_eyebrow:

:smiley: Trying to get too cute as I learn Python

1 Like

I see. Could you please: