Can't get Sony Cam to work


#1

My sony SLEH-00448 camera fails to produce a picture on Octoprint Control Screen

What did you already try to solve it?
I tried the configuration changes in octopi.txt listed on https://github.com/foosel/OctoPrint/wiki/Webcams-known-to-work, I ran some of them multiple times. I even tried some for other brands of cameras.
I did the following as recommended by - OCybress

Playstation Eye
•You may need to run a few commands to get it running. sudo -s rpi-update reboot

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)
running Version 1.3.9
camera is sony SLEH-00448 camera
I have an Ender 3,
I have been spending so much time on this camera issue, I have not even sent a file to the printer yet. But Octoprint seems to work otherwise, I can move axes with control, etc.

lsusb , two runs, the pi seems to recognize the camera...
https://drive.google.com/file/d/1q1EjYJUtistW-rS9JQpBUzPV0neJ8K--/view?usp=sharing
webcamd.log this shows lots of errors
https://drive.google.com/file/d/19jtD9oYsfS4g4W_89uZdy9CD8kfdbM1c/view?usp=sharing

its a good thing that Linux syntax is on the net, its been dozens of years since I played much with command lines, and very little unix at that.

thanks for all your help
Spamtownken


#2

OK, now I tried the third browser, and it works
I installed new firefox and my camera now works.


#3

Not really sure why the camera works now, but it does. I can't understand how changing browser helped. The last thing I did before that was plugging usb cords in different ports.

I have done a print, monitored it, all printer controls work, as far as I can tell.

oh well. Don't argue with success, even if it is accidental...
=|;o)


#4

Nice! And thank you for sharing your success!
Could you please tick the small box entitled solved at the end of you second post.
It helps other users that have the same problem to find a solution. Thank you!


#5

Was your first browser Internet Explorer? There is a known problem when using IE although Edge works fine.


#6

Actually first one was Edge, I then went through a whole bunch of gyrations over which browser supports Java, and your Java is out of date, etc. Is the Octoprint interface Java based?