Can't get stream to load except on octopi.local:8080

Using a sony playstation eye camera

No matter what i do i can't get the camera to show up under control. Ive got it working a couple of times but other than those rare occurences every time i load it up it shows it can't connect. Though when i go to octopi.local:8080 it shows my camera snapchat and stream working fine.

Ive tried different cameras, tried rebooting my pi after checking that the camera is in fact working properly by going to octopi.local:8080, edited octopi.txt with the information on the GitHub page that provides the list of working webcams.

Im not sure if this is the right information for logs but this is all im getting in my logs when i search for webcam

"2020-03-12 13:17:34,960 - octoprint.plugins.thespaghettidetective - INFO - Starting webcam streamer
2020-03-12 13:17:37,144 - octoprint.plugins.thespaghettidetective - ERROR - Backing off 0.300449 seconds: Failed to connect to websocket server
2020-03-12 13:17:37,622 - octoprint.plugins.thespaghettidetective - ERROR - Backing off 0.341218 seconds: Failed to connect to websocket server
2020-03-12 13:17:38,268 - octoprint.plugins.thespaghettidetective - ERROR - Backing off 1.013426 seconds: Failed to connect to websocket server
2020-03-12 13:17:38,284 - backoff - INFO - Backing off init_camera(...) for 0.1s"

Im using the most recent version of octoprint on a model 3b Pi. I got octoprint working 100% at home, took it to work where i want it set up at and couldn't get the stream to ever load; brought it back home and got the stream working once more but now i can't even get it to reconnect again here at home. these pictures are from last night showing the camera working, but now its only working on octopi.local:8080 and not on the control section of the client or in the webcam test window

Try Safe Mode and see if that helps.

Also, you didn't mention which browser you're trying to use.

Alright I’ll give that a try.

My bad, I’ve tried a mix of Firefox, chrome, and safari.

tried running it in safe mode and no change. The webcam still doesn't load under the control tab and still does at octopi.local:8080

You might also try http://octopi.local/webcam to see if that's the same.