Can't get webcam to work (logitech c310)

Camera model
Logitech c310

What is the problem?
The stream just won't start
What did you already try to solve it?
I tried editing octopi.txt to enable usb camera, i Added the -y at the end, i tried switching to a different fps (10, 15 and 20 with vga and 25, but only with 'HD'), i follow this post USB webcams known to work with mjpg-streamer
I tried rebooting into safe mode, as I saw somewhere it could be a conflict with plugins.

I ran lsusb, and it is detected by the raspberry.

Logs (/var/log/webcamd.log, syslog, dmesg, ... no logs, no support)
I can't find the webcamd.log.
here is syslog

Additional information about your setup (OctoPrint version, OctoPi version, ...)
I have octoprint 1.6.1 and octopi 0.18.0

Well, it works now ! The issue is that I edited the octopi.txt with wordpad, and it messed up some of the formating. A kind discord stranger helped me and told me to do this :
sudo apt install dos2unix
sudo dos2unix /boot/octopi.txt
and then it worked !!!