Can't get webcam to work

Camera model
Raspberry Pi camera v 1.3 from aliexpress (
What is the problem?
It worked for a few minutes when i tested it, and now it says "Webcam Stream loading" forever.
What did you already try to solve it?
I tried 2 different cables, unplugged and plugged again the SUNNY connector. Checked for updates, various reboots, different browsers, different pc's.
I also tried disabling and enabling webcam support on the interface.
I had an old USB webcam working before. This one worked for a few minutes before i unpluged everything and rebooted.

Edit: Tried now a fresh octoprint install, and the red LED only lit up when i did raspistill -o. Then got this:
Camera control callback cmd=0x4f525245mmal: No data received from sensor. Check all connections, including the Sunny one on the camera board

Logs (/var/log/webcamd.log, syslog, dmesg, ... no logs, no support)
I have no webcamd.log

I tried vcgencmd get_camera and it gives me:
supported=1 detected=0

When i try to do raspistill -o cam.jpg it says:
mmal: mmal_vc_component_enable: failed to enable component: ENOSPC
mmal: camera component couldn't be enabled
mmal: main: Failed to create camera component
mmal: Failed to run camera app. Please check for firmware updates

Additional information about your setup (OctoPrint version, OctoPi version, ...)
Octoprint Version 1.4.2
Octopi Version 0.17.0, running on Raspberry Pi 3 Model B Rev 1.2

The red LED on the camera was initially turning on only for a few seconds during boot, and then off. Now it is on after boot, and still no image.