Can't install Octoprint on Orange pi zero with armbian

What is the problem?

And at the stage of installing argon2 - an error:

Downloading argon2-cffi-bindings-21.2.0.tar.gz (1.8 MB)

  ━━━━━━━━━━━━━━━━━━│ :00:00

Installing build dependencies ... error

error: subprocess-exited-with-error
..... and so on

What did you already try to solve it?

Tried different distributions of operating systems and different installation scenarios.

Have you tried running in safe mode?

no

Did running in safe mode solve the problem?

no

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

no

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible
Orange pi zero, armbian

Hello @Dmitry_P !

Did you use a certain guide to install OctoPrint?

Sometimes stuff like that happens when you're using the wrong python version.

I would suggest you try it with this script

1 Like

you can use the recommended script, or sudo apt get libffi-dev should get you working.

I used automatic installation scripts, I used manual installation, I used different versions of armbian (latest and one year old) - the result is constant, the installation error of this particular module argon2-cffi.

I tried to install on 3.7, 3.9.9, 3.10.6 - the result is the same, an error occurred when installing the Argon module. This paukstelis installation script I also tried.

If I manually install libffi, then the OPI Zero board freezes when installing Argon2. I can wait 30-40 minutes with no result. Then armbian simply kills this process due to its inactivity.

Perhaps provide a complete log or terminal output of what is happening.

Log_SSH.log (8.7 KB)
Perhaps there is not enough swap file size?
At the installation the argon2, system freezes :frowning:

I kind of doubt that, unless there were changes made.
Is it the same result if you remove pip cache (rm -rf ~/.cache/pip) and remove the existing OctoPrint venv (rm -rf ~/OctoPrint)?

Manual install - Armbian - same issue here it hangs on this part:

Collecting argon2-cffi-bindings
  Downloading argon2-cffi-bindings-21.2.0.tar.gz (1.8 MB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 1.8/1.8 MB 6.5 MB/s eta 0:00:00
  Installing build dependencies ... error

you can work around by installing these in venv first:

pip install --force-reinstall --no-binary=argon2-cffi-bindings argon2_cffi

It than skips over, but does give a soft warning:

DEPRECATION: cffi is being installed using the legacy 'setup.py install' method, because it does not have a 'pyproject.toml' and the 'wheel' package is not installed. pip 23.1 will enforce this behaviour change. A possible replacement is to enable the '--use-pep517' option. Discussion can be found at Deprecate call to 'setup.py install' when 'wheel' is absent for source distributions without pyproject.toml · Issue #8559 · pypa/pip · GitHub

This seems like it has to be an issue with a particular Armbian build. Quite a few people have used octoprint_install script on OrangePi's without this issue.

I moved from Bullseye to Jammy - all issues solved. So it is indeed a particular Armbian build.

2 Likes