Can't load active spool! Possibly the wiring for the extruder

What is the problem?

Printer crashed, replaced components. Now I have an error saying "Can't load active spool!"

What did you already try to solve it?

Replaced heating element. Replaced thermistor. Replaced extruder motor pigtail. Fixed all wiring.

Have you tried running in safe mode?

No, I haven't even tried running the printer at all. I'm just checking basic functions. X, Y, & Z all move. Heating element gets hot. Temperature displays on the screen. Fans work. Extruder will not work.

Did running in safe mode solve the problem?

See above

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

I downloaded this. It is a lot of wordpad text documents. Which one needs pasted in here?

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint Version 1.10.2, Octopi version 0.18.0, Artillery X1, Octodash version v2.3.1, browser is chrome

I do not know if my filament error (active spool) is the only way that octoprint can tell me that my extruder is wired up incorrectly. The pigtails that are available come in different wiring configurations. I do not know the the wire colors that the artillery is wanting for the stepper motor to function. The pins on the stepper motor are referred to as + and - and coils, and center taps, and Phase B-CT, and it's very confusing to me.

The complete bundle to your next post.

Do not unzip it. (45 KB)

The error about selecting filament is completely different from anything related to your printer hardware. OctoPrint doesn't know anything about your printer's hardware, your printer should be able to operate without OctoPrint on it's own.

The error on the screen is from OctoDash, running your touchscreen, trying to choose the filament within the "filament manager" plugin. I would recommend logging in to the OctoPrint UI, on another device, to check that all your spools are setup correctly within the plugin's configuration.

I do not see filament manager as an available plugin

on the actual octodash, under plugins, I see "filament manager". But i can't click on it to open more info or settings. It just has an "enabled" checkbox. I'm assuming that this checkbox can only be toggled on/off.

i unchecked the enabed button. i'm now free of errors

1 Like

To explain in case anyone else comes across this, you didn’t have the filament manager plugin actually installed, but it was selected in OctoDash. Then as a result OctoDash was throwing the error because it was trying to access the plugin.