Can't Open Octoprint on Raspberry 4B+

I have downloaded and tried to install Octoprint now for over 2 weeks. I finally got it to Burn successfully to an 8GB SD Card using a Windows 7 Professional Laptop. I modified the Supplicant.txt file using Notepad++ and removed the 4 hash tags before entering the SSD ID and Password. I then installed the SD Card into the Raspberry Pi 4 B+ and using Angry Ip it wouldn't show up and when I checked the Raspberry Pi 4 B+ I noticed that the green light would flash intermittently for a few seconds and then return to a solid red. I tried using Raspberry Pi Imager and it refused to verify the install, whereas Win32 Imager managed to burn the image I downloaded from and extracted.
I am using Windows 11 OS Build 220000.376 on my main computer trying to access the Raspberry Pi 4 B+ with a Bell Canada 5G Network. I am trying to use the latest download of Octoprint.

So no red light in the first few seconds?
Sounds like the undervoltage indicator. Which psu are you using?

I am trying to use the power supply that came with this particular model when I purchased it. Turns out that it itself was severely under powered even though it was supposed to be an official Raspberry Product. Once I got it into favorable light, I was able to see that it only Output .5A. I just ordered a replacement from Amazon with a switch that outputs 3A. While that part maybe fixed. It still doesn't explain why Raspberry Pi Imager, Win32 Imager and EtcherBelana won't mount an SD Card or for that matter Burn to SD Card the Octopi.18.02 Image on a Windows 11 based PC.

Which size is the sd card?
If you're trying to write on an SDXC card with a cardreader that doesn't support SDXC cards it would explain your problems.

nvm - I missed the 8gb sd card part somehow.

All of the Cards I have are either EVO 8GB or Evo 32GB Class 10 Cards.

FWIW, I use 32GB cards without issues. I have multiple USB card reader/writers. I keep one of them in my OctoPi / OctoPrint system so I can clone the OS occasionally.

I checked again with a magnifying glass in better light and the official Raspberry Pi power supply outputs 2,500 mAH and my Pi is a 3 B+ not a 4. I'm going to try using the Ethernet Port instead of relying upon the WIFI Port. Still can't get Raspberry Imager to mount an SD Card for some strange reason, though a Microsoft 3rd level tech is going to be calling me back today or tomorrow.

Can you make a photo of the power supply'2 label and upload it here?

I have no way of taking a picture of said power supply.

Assuming the red power LED comes on, then the power supply at least works in some capacity. The red LED will turn off if the PSU is insufficient (undervoltage).

Connecting the Pi using a HDMI cable is often a good way of troubleshooting, as you don't have to worry about network connections. It will allow you to check via the command line why it might not connect to the wifi.

did you remove ALL the hashtags from the section AND set the country code?

Here's a short version that works if you enter your appropriate Country code, SSID and passwd

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev

ssid="your SSID"
psk="your password"

I used the Ctrl+ Shft+X method to enter SSID and Password along with the Time Zone and Country. After trying RPI once again with a new 32GB SD Card I managed to download and burn the Raspberry Raspian Full 32 OS without the slightest issue. It is my belief that the problem lies within the the latest image of Octoprint available for download. I was also able to Burn a Copy of the older Wheezy version of Octoprint without any problems. It all comes down to the ability of the Image Burning software making what is written, Verifiable. I've actually been able in real time watch Octoprint being written to a disc only to have it fail to mount the file.

Raspberry Pi Imager can install Octopi/Octoprint from it's own repository, no need to do a manual download

I've tried it at least a dozen times, from both repository and from I even went as far as having a level 3 Microsoft technician attempt to burn the image to an SD Card and he had the same results. The Raspberry Pi Imager refused to mount Fat32 on his factory system as well. Everything else we both tried would work perfectly with Windows 11 Professional and mounted from Raspberry OS both Lite and the Full Set, Twister OS worked and so did Debian Lite. It has to be something in the Octopi 18 that is causing Fat32 to fail to initialize. I am about to try and see if there is a 64Bit version of Octopi in the nightly releases. Otherwise, I have a 2 year old download of Breezy that I may try to get backup and running.

I just opened a new SanDisk Ultra Plus 32gb microSDHC card, used the Raspberry Pi Imager 1.6.2 on a Windows 10 system with the microSD card plugged into a UGreen USB 3.0 SD / microSD adapter, and successfully wrote the OctoPi 0.18 / OctoPrint 1.7.2 image selected from the Other specific purpose OS.

After removing and inserting the microSD card into the adapter, the /boot partition showed up (as P:) on my Windows 10 system. I edited octopi-wpa-supplicant.txt, added octopi-hostname.txt, and ejected the microSD card.

I inserted the microSD card into a Raspberry Pi 4B 4GB system and powered it up. I connected to the IP address (via the name in octopi-hostname.txt) over WiFi and completed the first time OctoPrint setup.

My conclusion after performing this experiment is that there's nothing wrong with Windows 10, the Raspberry Pi Imager, the OctoPi / OctoPrint image, or the procedure(s) posted.

I'm currently running OctoPi 0.18 / OctoPrint 1.7.2 on an RPi 3B connected to a LulzBot TAZ 6.

I don't doubt that you are having problems but I'm not sure exactly where things are going wrong for you.

In the very beginning you stated that you are running Windows 10. I had No Issues using RPI with Windows 10. What I am having issues with is what I thought were Windows 11 Professional problems and the 3rd Level Microsoft Technician from Microsoft Support Department for Window 11 was also having the same problems and couldn't get RPI to Initialize the Fat32 Mounting of the Sd Card when trying to create a burnt image of Octopi .18. RPI, Win32 Imager and Etcher aren't Mounting a burnt image to an SD Card in Fat 32. Using Octopi .18, they all have no issues mounting Raspberry Pi OS or Debian Linux. Just Octopi .18. It also doesn't have a problem mounting Octopi Wheezy, therefore something must be not Verifying correctly in Octopi .18 and this is causing an issue.

That must be a very old version - which version of OctoPi specifically?

I'm surprised, since the OctoPi image is basically RPi OS lite (from December 2020) with a few customisations, first time I've heard it failed to flash. You could try a nightly build so you are comparing current RPi OS images. Here: Index of /Distros/OctoPi/nightly

1.3.9 to be exact.

That is the OctoPrint version.

Up to now, the OctoPi versions start with a zero, e.g. 0.18.0